[Solved] Help connecting an AC1750 v4.0 to cable internet / DHCP (WAN gets no IP)

EDIT solved! I needed to power down my current router and wait a few minutes before plugging my new router, in order to let my ISP release their lock on my router MAC address. Thanks to pkgadd and DonkeyHotei from IRC :slightly_smiling_face:! Didn't know about that. To passersby, pkgadd on IRC says the ISP rationale for that is that "they use the MAC address as authentification - and want prevent users from getting two IPs at once (two routers connected to the same modem); IPv4 addresses are a scarce ressource, even more so for ISPs that came late to the party (cable, fibre, etc)"

Hi! I'm a network newbie and new OpenWrt user failing to configure a new TP-Link AC1750 v4.0 as home router connected to a cable modem connected to the internet.

Documented install of 18.06.0-ar71xx-generic-archer-c7-v4-factory went fine, I can reach Luci (at and using an ethernet cable, no wireless yet), but I'm unable to connect to the internet.

Looking at the Troubleshooting Internet Connectivity guide, I'm stuck at step 2 "Find the IPv4 address assigned to the WAN interface": my WAN has no IP! Inside Luci,

  • In Status / Network / IPv4 Upstream, I read:
     Protocol: Not connected
  • ... and in Network / Interfaces / WAN, no IP either on device eth0.2 (wan, wan6) using protocol DHCP.

On the LAN side, default settings too: Static IP

My previous router (TP-Link WR340G, stock TP-Link firmware) works fine connected to the same modem and using DHCP.

What am I doing wrong? Thanks!

1 Like