[Solved] have I bricked Netgear GS308T?

Finally I have made a brick by running this command via ssh, and then resetting.

fw_setenv bootcmd 'console=ttyS0,115200 ${mtdparts}'

I tried recovery by UART accessing. However their output was messed up:


I have tried 115200 8N1 serial parameter reported at git.openwrt.org Git - openwrt/openwrt.git/commit

  • UART (115200 8N1) via unpopulated standard 0.1" pin header marked J1


Anyone tried UART access against GS308T?

My steps until making brick:

  1. Installing OpenWrt successfully...
  2. It seems that "my settings are lost after each reboot."
  3. I want to make my changes persistent.
  4. I understood that I needed to modify MTD (Memory Technology Device) table. It is defined inside Linux kernel .
  5. Trying fw_setenv with dangerous parameters.
# fw_setenv mtdparts "mtdparts=spi-nor:0xe0000(u-boot)ro,0x10000(u-boot-env)ro,0x10000(u-boot-env2),0x100000(jffs)ro,0x100000(jffs2)ro,0xe80000(firmware),0xe80000(rootfs_data)"

# fw_setenv bootargs 'console=ttyS0,115200 ${mtdparts}'
# fw_setenv bootargs 'cmdline=console=ttyS0,115200 ${mtdparts}'

โ†“โ†“ This command BRICKED my switch!
# fw_setenv bootcmd 'console=ttyS0,115200 ${mtdparts}'

Have you tried using other baud rates for the UART? If the u-boot environment is now corrupted, it may be using a default value (38400 maybe? try a the standard ones).

If you are then able to recover your device, the correct way to get a persistent rootfs is to flash a sysupgrade image after installing the initramfs image.

You need to install an initramfs through the vendor GUI, because otherwise the appended squashfs would be stripped by the vendor firmware. Once you are running OpenWrt (initramfs), you can install a sysupgrade image like on other supported devices.

Generally OpenWrt ignores any kernel command line or partitioning from the bootloader, instead using the hard partitions defined in the DTS. There is nothing in the developer's notes in the git commit about repartitioning the flash. You should boot the initramfs and use it to install the sysupgrade. The initramfs is not suitable for production use since its filesystems are all RAM disk, so configuration file changes are only in RAM and won't be saved to flash.

Hi, thank you for helping me!

In next time I'll try sysupgrade image, after installing initramfs image.

p.s. I tried another baud rates like 38,400. But I couldn't see text output from uboot or such. There may be hardware issue around UART too. For now I have no good idea about how to recover this switch, so I'll dispose this one.


The normal baud rates to test would be 9600, 19200, 38400, 57600, and 115200 - 9600, 57600 and 115200 being the most commonly used ones for these purposes. Also make sure to (re-)confirm your soldering (GND in particular) and that the voltages are correct (Vcc mustn't be connected!).

1 Like

Hi, thank you for helping!

Also make sure to (re-)confirm your soldering (GND in particular)

Connecting to GND pin helped. I got text output, also typing text. (com parameter is 115200 8N1)

com4 115200

I could access to serial console.

FYI here is detail for later reference...

I have used DSD TECH SH-U09C USB.

About connection:

J1 | [o]ooo
      ^ ||`------ To GND (3.3 V) 
      | |`------- To RXD
      | `-------- To TXD
      `---------- Do not connect





Your bootloader is still good, so that should be pretty easy to unbrick. Hit any key when it says to, and you will see a menu. First go to the bootloader console and set the environment back to default. Then TFTP load the initramfs (requires setting up a TFTP server on your PC) and launch it from RAM.

Currently that switch is recovered with openwrt firmware!

I needed to tweak bootcmd at uboot. The initramfs was undamaged fortunately.

env set mtdparts
env set bootargs
env set bootcmd boota
env save

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.