[Solved] Guest Wifi not working as described in Wiki

Hello Forum,

I walked all the steps through the wiki article from https://openwrt.org/docs/guide-user/network/wifi/guestwifi/guest-wlan on my Linksys WRT1900ACS running OpenWRT 18.06.1.

But the Guest Wifi is not working correctly.
I do get a connection with the Wifi Network, but the (Android) client cannot achieve access to the Internet.

I suspect a DNS issue, since there is an entry in the dnsmasq log when the (Android) client connects to my regular Wifi network (checked via: logread | grep dnsmasq) but there is no such entry in the log, when the same client connects via the Guest Wifi.

Since I went through the steps in the wiki, I assume that there is something missing ?

Thank you for your assistance.


I have an WRT1900acs and I followed this easy guide for setting up a guest wi-fi network.

For testing, you could change the default input rule of the guest firewall zone to ACCEPT. This will make sure the guests can use the DHCP and DNS server in the router. They will also be able to reach the ssh and http servers, which is somewhat insecure (depending on how little you trust your guests).

WRT1900ACS running the latest build (18.06.01)

Followed the same setup link as spindoctor and couldn't connect to guest network (Android phone). Did a reboot through GUI and now it's working.

Hope this helps.

It's because the wiki was missing the command to restart the applicable services (network, dnsmasq, firewall):

  • cd /etc/init.d && ./network restart && ./dnsmasq restart && ./firewall restart

The final command is now:

uci commit && cd /etc/init.d && ./network restart && ./dnsmasq restart && ./firewall reload

@JW0914 thanks. Saw the final command was added to the wiki. Might be helpful to update #2 under Step By Step narrative to avoid any confusion for noobs like me. :smile:

Copy the whole following code block (from “ NETWORKID=guest … including up to the final …commit ) without the need for any changes or customization into a SSH command prompt of your LEDE device and press enter. (Alternatively if you prefer: create and run it as shell script on your LEDE device).

Thanks jasmithvr6 & JW0914,

rerun all the steps and apparently it works now :slight_smile:

Thanks for your help!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.