[Solved] GL-MT300A: wifi broken with newer LEDE

I have a GL-MT300A since a while that is used as an access point in my house.
Today I upgraded it to the latest LEDE 17.01.4

Result: as soon as WIFI is enabled the router crashes / reboots in a loop.
The only possible fix is to enter recovery and flash a fresh firmware.

I did more tests and it looks like the crash happens for stock firmware installation without any customization. Enable WIFI with default settings. Reboot loop.

The version openwrt-gl-mt300a-clean-2.264.bin from the GL.inet site works without problems.
The LEDE release 17.01.1 works without problems.
Releases 17.01.2 17.01.3 17.01.4 and the snapshot of tonight all crash the router.

Changing the WIFI mode to N or legacy did not help.

Just for reference, this is the (default) WIFI configuration that is being used in my tests:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/10180000.wmac'
	option htmode 'HT20'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'LEDE'
	option encryption 'none'

I have this problem as well. The GL-MT300A is stable on LEDE 17.01.1. However, once I upgrade to LEDE 17.01.2 or later, the device stays on for a minute or so and then seems to crash and reboot. I'm not sure if it is due to WiFi or some other change in 17.01.2.

As you see my post is quite old. It seems that nobody ever cared.
Unfortunately, as it is a nice little router.

I tried all the 17.01.x versions with fresh installs and they all crash
(except .1)

I submitted a bug to the LEDE tracker here:

It would be nice to get this device stable on latest LEDE. The GL-MT300A makes for a good travel router as it is very small and more powerful than others of similar size. It also has a LAN and WAN port + USB for extra storage. Also it is cheap (~$20) and runs Openwrt out of the box from the manufacturer.

Ok, thanks, I added some knowlege there.

I was able to resolve this by using a more powerful USB charger. I was using a 5W iPhone USB charger and was getting crashes/reboots. I upgraded the charger to a 10W iPad charger and now it seems to stable now on 17.01.4.

Try replacing your power charger and see if it runs better.

My MT300 also runs fine on 17.01.4, but is indeed picky about its power supply. It reboots when it can't get enough power, so try switching to a different power supply before trying anything else.

Thank you, I will test it.
We should close the bug report in this case.

When you confirmed that the power supply was the issue and your question is solved, consider marking this topic as [Solved].

Ok I will do so.

I took way to long for me verifying the fix, but finally I found time.

Using a stronger power supply fixes the reboot issues. I have now 18.06 on
the device and it runs flawless.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.