[Solved]Getting MC7455 and AR9462 to work on APU2C4

Hy everybody,

i`ve already posted another Thread because i was not able to install packages.

So now the next problem, i will include as most information as i can.

i downloaded the OpenWRT Image Builder and builded an Image with following packages included:

Link to installed packages(kmod-owl-loader and wpad are also installed)).

What i saw from the dmesg my wireless card did not initialize when starting up.

Same with the MC7455 LTE Modem.
But i think the MC7455 get recognized and i simply dont know how to find out the correct /dev/tty**** device which to choose from.
Also when choosing PPP when adding an Interface you can only type in the APN Username/Password but there no option to give the LTE Modem an APN-Adress

As you can see from the list above i have installed every needed package for them.

Heres the output of:

lspci -knn

lspci -knn

Heres the output of:

lspci -vvv

lspci -vvv

Heres the output of:



When i go to the Webinterface theres also no wireless option under networkings tab available.

Here is your Atheros wifi card enumerated on the PCIe bus:

04:00.0 Network controller [0280]: Qualcomm Atheros AR9462 Wireless Network Adapter [168c:0034] (rev 01)

However I see no activity from ath9k in the bootlog. Use lsmod to confirm ath9k modules are loaded into the kernel.

LTE modems are almost all actually USB devices. The PCIe specification includes a USB lane. Some PCs do not have a USB port wired to every slot. Also some mini-PCs do not have the PCIe lanes wired to all the slots, some are USB only.

In your case though the LTE card is detected and taken by the qserial driver:

[    8.499260] usbserial: USB Serial support registered for Qualcomm USB modem
[    8.506787] qcserial 1-1.3:1.0: Qualcomm USB modem converter detected
[    8.513534] usb 1-1.3: Qualcomm USB modem converter now attached to ttyUSB0
[    8.521604] qcserial 1-1.3:1.2: Qualcomm USB modem converter detected
[    8.528434] usb 1-1.3: Qualcomm USB modem converter now attached to ttyUSB1
[    8.541409] qcserial 1-1.3:1.3: Qualcomm USB modem converter detected
[    8.548338] usb 1-1.3: Qualcomm USB modem converter now attached to ttyUSB2

Hy mk24 i tried lsmod i simply post the output:

but yeah a ath9k is listed there.

lsmod output

*When it comes to the LTE Modem why is there a Qualcomm USB Converter loaded when i have a **Sierra Wireless** MC7455?*

Found out that this card is based or has a MDM9230 built in from Qualcomm

So now we know that the driver module is loaded how to get the Wireless option on the Webinterface.

And much more important, how to get the MC7455 to work?

you need to compile image with ATH9K_SUPPORT_PCOEM option set to y ("Support chips used in PC OEM cards") for AR9462 to work

I also read that somewhere but cant figure out how to do it.

i dont know which file i have to edit and which line of the file i have to make the configuration.

Did i have to do this change(s) in the mac80211 makefile(file)?

If yes.

Please advise me how to do what on which line!

Thanks alot

when you run make menuconfig:
Location: │
│ -> Kernel modules │
│ -> Wireless Drivers │
│ -> kmod-ath9k

I also have 1 of these in the field.
The correct one to use is the last one.
In your case it's ttyUSB2

But it's not required when using QMI iso ppp ( qmi uses /dev/cdc-wdm0)

Also make sure you flash the latest firmware to the modem or you will run into issues :slight_smile:

Is there an Documentation or a How To on how to update the firmware?
because im not able to stick this modem into an Windows PC where a One Click Software exists.

can you be more detailed please?
I dont unterstand where this tree structure is? is that at the index on the OpenWRT Site?
where do i have to execute this command? in which layer of folders?
About these topic theres not really much information on the internet beceause its very specific.

I really appreciate that you give hints but for someone who never had build a kernel or software himself is really hard to not possible to achieve this without a step by step how to.

also others here in the forum will benefit from your information.

i search for pcoem config and many other possible synonym but found nearly no information about it and never mind to compile it.

you go to: https://openwrt.org/docs/guide-developer/source-code/start
copy and paste clone command into your terminal, run it
switch your terminal to cloned directory
next go to: https://openwrt.org/docs/guide-developer/build-system/use-buildsystem
in section Updating Feeds:
execute 1. Update feeds:
execute 2. Make downloaded package/packages available in make menuconfig : (all packages:)

after that you run make menuconfig and choose your build profile and settings

in the end run make (or make -j 5 for 4core CPU) and get built image within an hour or less

hope you didn't expect to just download something and install, as for this option you need to build from source

right now im in the process of trying it..

thanks alot in advance!!!!


Looks like its working.. Compile is in process!

Thank you!!!
I will write a Tutorial about this with this specific build with my APU2C4 and the mc7455 paired with the atheros chipset which needs PCOEM Support activated

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.