[SOLVED] FTP port forward

Details 200 Type set to A 227 Entering passive mode is the error I get with FTP in explorer

I never had this issue before on my other router I just checked enabled 21 on Port Forward

I have other ports open and they are working for other services but I can't seem to get FTP port 21 to work.

I tried to google and someone said to try the NAT tab I tried that with:

External and Internal / Source and Destination:

In ever combo possible:

I'm at a loss here I legit attempted different settings under:

Port Forwards and NAT Rules as well as trying to add port 21 under Traffic rules even.

I have no clue to why I can't connect via FTP on port 21.

I even got tired of retyping the user/passwd for ftp so I installed Cyberduck FTP since it remembers creds

I can't seem to get in the server at all.

Any help would be much apprech.

1 Like

Make sure to install:

And restart the firewall service.

I installed the package kmod-nf-nathelper and that seemed to work :confused:

Any reason why it did not work with out that package that I should be aware of ?

Also do I is there a page to configure this package or is it just a stand alone...

It appears to work tho. thanks for the input. kind of confused to why I needed that for FTP to work.

1 Like

Also I was changing stuff for nearly 3 hours please tell me if this firewall page looks default.

Idr if I had changed something on that page to try to force FTP to work that I should have not.

Configuring firewall for cross-zone FTP connections - #7 by vgaetera

Yep, looks fine.

Ok thank you! one last thing would be be a good or bad idea to tick box "Drop invald packets"

1 Like

It is disabled by default, but should work for most cases if you decide to enable it.
However, enabling that feature may result in packet loss for some type traffic such as P2P, BitTorrent, gaming, streaming, etc.

copy that thanks again.

I should have came to the forums sooner instead of waited so long trying to force FTP LUL cheers man!

1 Like

well I noticed after I installed that package I'm able to access FTP on the LAN side of things.

So it kind of works, but I'm still not able to access it from outside the WAN.

would I need to add a NAT filter for that ?

I have the port forward working and it works on LAN but not WAN.

1 Like

Try to enable conntrack helper:
Port Forwarding Issues - #3 by vgaetera

If the issue persists, post the output:

iptables-save -c -t raw; sysctl net.netfilter.nf_conntrack_helper

Alright so I edited sysctl.conf and enabled conntrack helper then restarted sysctl

It's kinf of a little bit slow, but I'm able to get a connection from WAN now.

I'll have to test more connections outside of LAN later as its pretty late for me.

...but so far much progress big ups!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.