[SOLVED] FRITZ!Box 7520 averaging 75°C

Uuuuhhhh so I'm running 23.05 and the system load is always very low (I add screenshots):

I don't really think this is normal and I don't think it is a software related problem, I don't live in a particular hot place and the router is on a shelf, not closed in a cabin or somewhere without air flow.
What could I do? I thought about putting an heat sink but maybe someone have a different experience and suggestions?

Thanks everyone in advance!

While I don't have ipq40xx reference temperatures handy right now, ARM has a tendency to run hot(ter) (and the modem hardware will also contribute), likewise AVM's thermal design has always been criticized, so that's not necessarily worrying…

I'd probably hang the router vertically for a comparison (small side up), that should help with a slight chimney effect (the venting holes aren't really big enough for a major improvement, but you might still see a slight one). I've seen temperatures around 80°C on my nbg6817 (ipq8065, so kind of its bigger brother), not great, but as mentioned, ARM is running hot.

And you don't experience anything like random reboots? Sometimes my router reboots and I can't really understand why, performance are not impacted and I never have a spike of system load (sometime the reboot is caused just by the electricity line around here, in the last month it became very unstable, especially when it rains...).

All the above brought me to investigate, and discovered the temperature thing.

Could be a faulty or too weak power supply.
Maybe try it with another, more powerful one, see if it fixes the problem.

1 Like

If you give me a few days, I can check on mine. I do not experience any stability issues.

1 Like

So I was able to install everything remotely, it won't take a few days :wink:

Both ath10k sensors report 77C for me. This is with under very light load with only a few 2.4GHz clients and no 5GHz clients connected.

Judging by the name, the sensors are not the CPU temperature, but very closely related since the WiFi chips are part of the SoC. My device is in a cabinet right beneath a Raspberry Pi 4. This temperature, if it's correct, doesn't surprise me. The (passively cooled) Pi4 is running at 55C at the moment.

1 Like

Thank you @andyboeh, I guess this is normal behavior then.
I'll try with a different power supply, just like @dnd suggested.

Thank you all for this discussion, marking as solved.

Ah, I forgot to mention that: mine is driven by an Eaton 12V Mini-UPS, not by the stock PSU.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.