[SOLVED} Fresh install OpenWrt 18.06.1 on Netgear WNDR3800 - no space left for installing packages

I just installed 18.06.1 via TFTP on my Netgear WNDR3800.
I have not installed any packages.
Initially software page said I had 96% free space (11.39MB)

After just changing network settings and browsing through software package (installing notihing) the software page says: 2% (212 KB) free space. So I cannot install packages.

root@OpenWrt:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 2560      2560         0 100% /rom
tmpfs                    62648      1160     61488   2% /tmp
/dev/mtdblock5           12160     11948       212  98% /overlay
overlayfs:/overlay       12160     11948       212  98% /

What can I do?

Your overlay is filled up to 98% with something. Free space there. Sounds strange if you really used tftp and the official image.

Easy option is to run "firstboot" that clears all settings and extra files. Then reboot.

No idea what you are talking about as wndr3800 has only 16 MB flash.

putty your router

umount /overlay && jffs2reset && reboot

hopefully this will help ya

OK, I did install officlal package;
Just executed the 'firstboot' command.
Refreshing the software page now gives 93% free space. So this did something
No rebooting

Please reboot to get everything initialised normally

Because all settings were cleared, I first had to redo my network settings ( for IP of openwrt), to be able to reach openwrt again.
When I try to install domoticz, I get:

  • opkg_conf_load: Could not lock /var/lock/opkg.lock: Resource temporarily unavailable.

Just issueing command: umount /overlay && jffs2reset && reboot

The domoticz package is very large (~9MB) and can easily fill up the ten or so free MB you have in your overlay. Is it the only package you tried to install or did you install other things before?

no this is the only package I tried to install.
I see that it is too big.
THe amount of free space is 6.71, (56%) but is now stable. The issue was that this amount decreases to 1% without installing any packages. THis problem seems to be solved!

Thanks for all your prompt replies!!!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.