[Solved] Failed flashing firmware, maybe permanently bricked

I had been getting very well with LEDE and Openwrt before a critical accident happened two weeks ago.
A few months ago, I already succeeded in flashing LEDE(openwrt) firmware into my router and happily enjoyed LEDE which gave me wonderful functionalities including tftpd, samba, NAS etc.
Lately I challenged myself to deal with Transmission, the torrent client, which is my best interest, and I also succeeded in installing and configuration and had used it until I failed in re-flashing the same firmware after realizing that Transmission was not working properly.
I have tried to re-flash the firmware again and again, which resulting in same failures.

  • Router(or AP) : Buffalo AirStation WZR-HP-G450H (manufactured by BUFFALO INC in 2012)
  • OS : Windows 10
  • Procedures I followed according to the guide of LEDE
    1. IP confiruration

      Change pc side ip
      subnet mask,
      gate ip :

    2. ARP route

      netsh interface ipv4 add neighbors 10 02-aa-bb-cc-dd-23

    3. Upload firmware

      tftp -i PUT lede-17.01.4-ar71xx-generic-wzr-hp-g450h-squashfs-factory.bin * 'DIAG' LED not flashing rapidly.

    4. Result from 3

      Transmission completed, 31,525,434 bytes in 1sec, 31,525,434/sec * it looks succeeded without 'DIAG' LED not blinking.

    5. Make IP of my pc with DHCP, remove ARP route and the router never recovered from bricked state.

I guess the firmware is maybe permanently dead. I have survived my router more than 10 times from brick and I want to think of buying new router after listening carefully to the experienced people here in the forum, if there would be no solution.
One thing very wired for the what I noticed during my procedure is that local network connection repeats "identifying..." and "not connected" and at the same time the 'DIAG' LED of the router keeps on and off repeatedly whether the serial line is connected or not.
Is there any one to help me to reach further challenge and get happiness?

The best way to see what is going on would be a serial console.

You can try connecting an Ethernet switch between the PC and the router. This way the PC always has an Ethernet link and doesn't reconfigure the port while the router is booting.

Thank you for the quick comment, mk24.

30 Megabytes?
That is strange because the OpenWrt/LEDE images are much much smaller.

And you should upload the tftp image, not the factory one.


Download the file, follow the same procedure and the router will recover from the soft brick state.

When you say "I have survived my router more than 10 times from brick", what do you mean? Because if you were doing the same thing as you do now (uploading the factory image) in order to unbrick it, there is no chance the router would ever recover.

Thank you very much. I could make it to recovery at last.
As you said, I kept uploading wrong images that are factory or other wrong ones.
I still wonder why I could'nt get the right tftp image. At LEDE site, I followed some links which guide me to my device firmwares ; Supported Devices > Tables answering your questions > Where can I download LEDE firmware for my router? > search my device. The result didn't give me any tftp image and I thought that one of two firmwares is the right thing I was searching.
At first I didn't expect my device would be alive again, same even when I saw your comment.
Yesterday, I bought a 'USB to TTL serial cable' for last try that seems very complicated procedures according to some references, of course, it's no use now. I fixed my device!
I feel strong power of good community and I will enjoy coming weekend with LEDE.
I appreciate that you understood my situation very well and even gave me big help. Thanks again, angelos!
PS : Sorry for my one mistake. the image size is 3 megabytes not 30 megabytes as you said.