[Solved] Factory Reset not activating after holding button?

I crashed my EX3700 that's running OpenWrt by --force-depends installing ebtables. The kernel version I have installed is the same number in the dependency except it had a dash at the end and some the letters or words. I figured that just meant it was a custom build and since the actual version number was the same that it would be OK to force install the package. As soon as it finished installing the package, the device rebooted and had a solid red light. It went into an endless bootloop after that.

I pressed a button repeatedly until the green light started flashing rapidly, then I held the factory reset button for 10 seconds and released it. The green light kept flashing rapidly and at the same speed as when it entered "fail safe" mode. Is the light supposed to change color or is the light supposed to blink at a different speed when it starts a "factory reset"? I left it alone for about 5 minutes and it still appeared to be in "fail safe" mode with the green light flashing rapidly.

I power cycled the device and repeated the process except this time I held the factory reset button for thirty seconds after it entered "fail safe" mode. The light is still green and blinking rapidly like it's in "fail safe" mode. Am I doing this correctly to initiate a factory reset?

No, as you noticed, you'll enter failsafe mode - what to do from there is your decision (the obvious one would of course be to ssh into it and to invoke firstboot)

1 Like

I only have wireless access to it at the moment which is why I was trying to do a factory reset. It's running a custom build that includes my /etc/config/wireless, /etc/config/network and /etc/config/firewall files so that it connects to WiFi on it's first boot.

Factory Reset
A factory reset returns your router to the configuration it had just after flashing. This works on any install with a squashfs / overlayfs setup (the norm for most installations), since it is based on erasing and reformatting the overlayfs.


Does this function not exist in the firmware anymore, or does it not work properly on some devices?

Wireless access is not available under failsafe conditions, and as described in that wiki page failsafe will not reset on its own - it merely gives you shell (ssh) access via ethernet to either fix up the situation manually or to invoke firstboot to actually reset the device.

1 Like

I'm trying to do a factory reset as described under the fail safe section in the wiki. If the device were restored to the state it was in directly after flashing, then the WiFi would come up after it boots up there first time.

Reset Button
On devices with a physical reset button, OpenWrt can be reset to default settings without serial or SSH access.

Power on the device and wait for the status led to stop flashing (or go in Failsafe Mode above).
Press and keep pushed the Reset button for 10 seconds.
Release the Reset button
The device will do a Hard Factory Reset (see below) and then reboot. On some devices this operation can be slow, so wait a few minutes before connecting again

It's hard to see in this photo but between the antenna and the two buttons on the right, there is a pin hole button in the center. Under the button it says "Factory Reset"

The button on the far right is the power button and the one to the left of that is the WPS button. I was pressing the WPS button to get into failsafe mode but when I held the factory reset button afterwards it didn't do anything.

I'll try to hook it up to ethernet in a few minutes and see if firstboot will fix it. If all else fails then I can use the Netgear flashing utility. I was hoping the factory reset worked because I wouldn't have to unplug it and move it to another room to work on it.

Factory reset depends on booting up fully. Since your present configuration crashes before it boots up fully, you can't use factory reset.

What you want is failsafe. Do not press any buttons at first when powering up. When the LED starts flashing rapidly, press and release one of the buttons (which one depends on the button definition for the model) up to several times. If successful, the LED will change to flashing very rapidly.

In fail-safes your ROM configuration is active, so with a custom build that brings up wifi, wifi will be active. The overlay partition with additional packages installed at runtime, is not active. The firstboot command will erase that partition so that the next normal boot is only what is in ROM, but with the ability to reconfigure and install more packages.

1 Like

I was able to activate failsafe mode but my wifi never came up. I ended up flashing the latest stable image with nmrpflash and copied my configs over that I had backed up on my PC.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.