[SOLVED] ESPRESSObin, Add PCIe Wi-Fi Card

Thanks! Do you happen to know your HW version? Asking because,

Thanks! Will give this a try. Didn't know that I needed kmod-iwlwifi ... that's part of my confusion, I admit => knowing which items to add to the build.

Appreciate it!

carl9170 is a good driver, but it's still not good at providing AP services (I've tried it for a few years, don't recommend that experience at all) - you will experience 'unexplainable' connection stalls and the number of connecting clients is also rather limited.

USB wireless is unsuited for AP uses, outsource this functionality to a dedicated concurrent dual-band 802.11ac/ax AP running OpenWrt and forget about it. Even a cheap one will beat any USB solution, by a fair margin, let alone the added reliability.

1 Like

OK, that (sort of :laughing:) worked - thanks! With kmod-iwlwifi added, now I can configure wireless, enable it, but still a couple things (of course ... LOL),

  1. If frequency is set to auto, it won't enable. Not sure why, and not a biggie ... just set a fixed frequency.
  2. A bit more of an issue, the SSID is not "seen" by other devices => meaning I think it's still not quite working yet. Have you seen this before?

Thanks again!

Actually, I just noticed that it comes up showing 5 GHz only (just assumed it was right, but noticed it's not). Hmm ... need to figure out why that is.

Thanks!

All working now - really appreciate the pointers. Thanks!!

Interestingly enough, I'm seeing kernel crashes with the iwlwifi driver ... have you seen similar issues? Should I capture the info, open a bug report?

Thanks!

No, I haven't seen these. But I also don't use Intel cards for access points (I did briefly a few years back for testing purposes, so I really have no experience that would apply to a much newer kernel).

First thing I'd try is to google the error messages you get in the log. That sometimes gives a hint. But in general, I find debugging wireless issues with OpenWrt a bit harder than usual since OpenWrt uses a newer version of the wireless subsystem and drivers backported to an older kernel with many patches on top. Hence, it's not as simple to figure out, if the bug is in the upstream kernel or specific to OpenWrt due to the backports and patches. So, if your google search doesn't turn up anything, I'd suggest opening a bug report on the OpenWrt Github Issues page and hope that some developer can make more of it.

Will do - debug, and if I get stumped => bug report, like you say. Thanks!