[SOLVED] Errors compiling images (imagebuilder)

Hi, COmpiling the image I received these errors.

  • I downloaded the builimager for Ralink -> RT5350 -> ramips -> rt305x
  • Installed This required: apt-get install subversion build-essential libncurses5-dev zlib1g-dev gawk git ccache gettext libssl-dev xsltproc wget unzip python

PROFILE_NAMES = Default DEVICE_GEVA DEVICE_px-4885-4M DEVICE_px-4885-8M DEVICE_carambola DEVICE_a5-v11 DEVICE_w502u DEV$Default_NAME:=Default Profile
Default_PACKAGES:=kmod-usb-core kmod-usb-dwc2 kmod-usb-ledtrig-usbport iwinfo

Copied this GEVA.dts on target/linux/ramips/dts/GEVA.dts

Any idea what these errors can be?
Ubuntu on Windows 10
All updated.

Help, Help
Same errors also compining existing profile.

Packages have been updated for a newer kernel version, so you'll need to clean your build directory. I've never used imagebuilder before, but with a buildroot, you'd issue make clean && make V=s

  • Occasionally I've had to run make dirclean if make clean didn't fix the issue, but normally the former isn't necessary.

Same errors, you can check here message:

make clean
make image PROFILE=a5-v11
make image V=s PROFILE=a5-v11

make dirclean
error is:
make: *** No rule to make target 'dirclean'. Stop.

Looks like it can't find the needed kernel modules

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for firewall:
 *      kernel (= 4.14.41-1-70853d3102a6b9e13d13d6c063af2fea) *         kernel (= 4.14.41-1-70853d3102a6b9e13d13d6c063af2fea) *     

While it was recently announced that there would be a "more reasonable" period of time that kernel modules would be available for project-built snapshots and that the "opkg" reference would be in the image, that may not have been integrated with the image builder.

I do not understand.
Missing any modules in the download?
Do the developers read this post and add them?

I tried to compile imagebuider from the sources, even if I have some Warning that I do not understand.
But when I compile the image I have these errors.

Collected errors:

opkg_install_cmd: Cannot install package kmod-usb-ohci.
opkg_install_cmd: Cannot install package kmod-usb2.
Makefile:134: recipe for target ‘package_install’ failed
make[2]: *** [package_install] Error 255
Makefile:100: recipe for target ‘_call_image’ failed
make[1]: *** [_call_image] Error 2
Makefile:175: recipe for target ‘image’ failed
make: *** [image] Error 2

Full Warning and message

Please issue make V=s and post the error output (usually last 10 - 15 lines)

This make of Image Buider compiled from sources.
Or you mean donwload Image Builder ? Or Source compiler ?

make V=s
Available Commands:
help: This help text
info: Show a list of available target profiles
clean: Remove images and temporary build files
image: Build an image (see below for more information).

Building images:
By default 'make image' will create an image with the default
target profile and package set. You can use the following parameters
to change that:

    make image PROFILE="<profilename>" # override the default target profile
    make image PACKAGES="<pkg1> [<pkg2> [<pkg3> ...]]" # include extra packages
    make image FILES="<path>" # include extra files from <path>
    make image BIN_DIR="<path>" # alternative output directory for the images
    make image EXTRA_IMAGE_NAME="<string>" # Add this to the output image filename (sanitized)

When you go to compile the image with ImageBuilder, however, from your output, it appears it doesn't support a verbosity setting?

  • V=s is telling make to output the verbosity level as system.

Also, please post code, config, and log output within code boxes... please see this post for the three ways to do so

This whole discussion is a mix of

a) limited "imagebuilder" that is used to cook up firmwares quickly for from existing kernels & packages
b) full toolchain that is used to compile images from scratch, from raw source.

I think that adding new devices is more suitable for full toolchain, so you might familiarize yourself with that and use it. It is not that complicated.

1 Like

Using the toolchain, I do not understand where to modify to customize the GPIOs, and RAM/Flash size.

On the toolchain, How do I solve these warnings ?
I can not find those libraries, like the libpam, in make menuconfig

WARNING: Makefile 'package/utils/busybox/Makefile' has a dependency on 'libpam', which does not exist
WARNING: Makefile 'package/utils/busybox/Makefile' has a build dependency on 'libpam', which does not exist
WARNING: Makefile 'package/network/utils/curl/Makefile' has a dependency on 'libgnutls', which does not exist
WARNING: Makefile 'package/network/utils/curl/Makefile' has a dependency on 'libopenldap', which does not exist
WARNING: Makefile 'package/network/utils/curl/Makefile' has a dependency on 'libidn2', which does not exist
WARNING: Makefile 'package/network/utils/curl/Makefile' has a dependency on 'libssh2', which does not exist
WARNING: Makefile 'package/boot/kexec-tools/Makefile' has a dependency on 'liblzma', which does not exist
WARNING: Makefile 'package/network/services/lldpd/Makefile' has a dependency on 'libnetsnmp', which does not exist
configuration written to .config

That kind of output is indicative of an incomplete or inconsistent set of feeds, which can often be resolved by (as called out in the build-system instructions):

./scripts/feeds update -a
./scripts/feeds install -a

Tanks, solved with.

./scripts/feeds update -a
./scripts/feeds install -a

Warning there are no more.