[SOLVED] Error: Network device is not present

[SOLVED] :
TL;DR:
When creating a bridge with wireless interface, wireless interface should not be added to the bridge on the network settings (Luci / network page / file /etc/config/network)) but each wireless interface should be assigned to the network on the wireless settings (where you enter the wifi passwrd : Luci / wireless settings / file /etc/config/wireless)

Hi,
I just flashed a TP-Link RE350 with Openwrt 19.07.4 with the TP-Link interface (i try tftp, but doesn't work). Strange fact, the firmware for this router is available but the openwrt page says the last version available is 18.06.2 (because 18.06.4 is too large). But this router have 8MB Flash/64MB Flash
The TP-Link RE350 is Range Extender with a Gigabit Port and 2,4/5Ghz WIFI

What i want is simple : ethernet port on my wired network (10.4.0.0/16), wifi ports on their own networks (192.168.146/23). DHCP server for wifi network, and no Firewall, no nat (wired host will have the required routes).

So i create, with Luci , a new interface (lan2), bridged, and select interfaces wlan0 (2.4) and wlan1(5) , deselect thoses interfaces from lan interface, assign static ip to the interface, save, reboot
In Luci, it says "Error:** Network device is not present". The tooltip on the bridge says not connected. brctl show only display the br-lan bridge. My /etc/config/network. logread say no errors.
config interface 'lan2'
option proto 'static'
option ifname 'wlan0 wlan1'
option type 'bridge'
option netmask '255.255.254.0'
option ipaddr '192.168.146.1'

I try with only wlan0, it worked once, but do not work anymore. It says ""Error:** Network device is not present"

How can i fix this ?
Thanks
Regards,
Angus

Don't reference wifi interfaces in /etc/config/network. Change the network in the wifi config /etc/config/wireless. If a network consists only of wifi interfaces, there won't be an option ifname at all in /etc/config/network.

The reason for this is that the wlanX-Y names are generated at runtime and may change.

1 Like

Thanks for the fast answer.
In the meantime, i reconfigure with no bridge and only 2.4Ghz... works.
When i see your answer, i re enable 5Ghz by adding the line "network" in wireless.
Luci only display the "wlan0" (2.4) on the interface lan2, and in the wireless settings, the wlan0 and wlan0 are linked to network lan2.
Only client on 2.4ghz receive ip adress from dhcp.
the command "ip a" shows that only wlan0 has the ip adress
/etc/config/network :
config interface 'lan2'
option proto 'static'
option ipaddr '192.168.146.1'
option netmask '255.255.254.0'

/etc/config/wireless:
onfig wifi-iface 'default_radio0'
option device 'radio0'
option mode 'ap'
option key '*********'
option encryption 'psk2'
option network 'lan2'
option ssid 'AngusWorld'
config wifi-iface 'default_radio1'
option device 'radio1'
option mode 'ap'
option key '
'
option ssid 'AngusWorld'
option encryption 'psk2'
option network 'lan2'

Ouch. I got your point. The interface should be bridge with no wireless interface, and i have to set the network on each in wireless settings.
Seems to work like that

Yes It works.
Many thanks to you mk24.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.