[SOLVED] DNS problem on OpenWrt as openvpn or WireGuard client

Hello everyone

please help me to understand where is the problem

I am using windscribe paid vpn service

and trying to configure my openwrt router as VPN client

I can say I am succeed in configuring in both cases as openVPN and as WireGuard

I used this instruction for example


but problem is ` when I am putting DNS IP address in wan config ( for windscribe)

and apply changes it starts work my devices connected to openwrt start using vpn

but after reboot of openwrt WireGuard (openvpn havesame issue) connection goes down

nothing helps until I don't delete DNS ip , then reboot, then again put dns ip to wan

and it starts work perfect until next reboot

instead of wireguard I used openvpn but it stop working after reboot - same problem after adding DNS

I tryed to add DNS ip to other interfaces

also to lan interface

nothing helps

somebody help me to understand whats going on :slight_smile:

adding dns ip to client side and removing from wan helps


but I dont think it is nice and right way to do it

it is better get settings from openwrt

If the VPN is supposed to be up 24/7, you can use the DHCP to announce the DNS using option 6, as in https://openwrt.org/docs/guide-user/base-system/dhcp_configuration#dhcp_options

1 Like

to wan or lan?

I sure hope the DHCP's only running on the LAN side.

1 Like

The lan interface-> Advanced settings

1 Like

uci add_list dhcp.lan.dhcp_option="6,"

or like this? because from luci only when I add DNS to wan it works until reboot

uci add_list dhcp.wan.dhcp_option="6,"

I wrote it doesnt help :frowning:

thank you both

I am trying 2 days to figure out
and also tried adding dns IP to LAN

just now once again tried and it works !! :slight_smile:

mystery :slight_smile:


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.