[solved] Default gateway not working (RPI4 Snapshot)

Hello.

Sorry to bother you guys but I'm stuck on this since days and I can't figure it out.
The short story: I've an old Rpi 1 running "LEDE Reboot 17.01" that I want to replace/upgrade by a Rpi 4.

So, I took the latest snapshot for the Rpi 4, installed everything necessary, configured it the same way as my old Pi, but I can't get my clients to connect to the Internet.
I've Internet on the Rpi4, my clients got well an IP and correct gateway/DNS, but they are unable to connect to the Internet, even by IP.

I compared settings from the old Pi and the new one, everything is the same and using OpenWRT since more than 4 years, I'm pretty familar with it but here I really don't see where can be the issue.

The setup is as follow:
LAN with IP 192.168.1.1 on eth1 (USB RTL8153 Gigabit Ethernet Adapter)
WAN with IP 192.168.2.8 on eth0 (built-in Pi Ethernet, connected to a 4G Router with IP 192.168.2.1)
And I have disabled the built-in wlan to avoid conflict.

/etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdc6:6381:045c::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.1'
	option gateway '192.168.2.1'
	option ifname 'eth1'
	list dns '1.1.1.1'
	list dns '8.8.8.8'

config interface 'internet'
	option proto 'static'
	option delegate '0'
	option ipaddr '192.168.2.8'
	option netmask '255.255.255.0'
	option gateway '192.168.2.1'
	option ifname 'eth0'
	list dns '1.1.1.1'
	list dns '8.8.8.8'

/etc/config/firewall

config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option src_ip		fc00::/6
	option dest_ip		fc00::/6
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT

/etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '2h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option force '1'
        list dhcp_option '37,65'
        list dhcp_option '6,192.168.1.1'
        list dhcp_option '3,192.168.1.1'
        list dhcp_option '4,192.168.1.1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

ip -4 route

default via 192.168.2.1 dev eth0
192.168.1.0/24 dev br-lan scope link  src 192.168.1.1
192.168.2.0/24 dev eth0 scope link  src 192.168.2.8

On the clients, gateway and DNS are well set to 192.168.1.1.

Any clue will be really welcome... :slight_smile:

Thank you.

try removing the gateway statement from your 'lan' stanza in /etc/config/network...

the 'route' command output looks ok... but as that gateway is listed already in the appropriate interface... i'm not sure you need to list it in 'lan'...

Useful info... that's when you traceroute to each hop in the chain... ( from a client )... to gain more info... usually people overlook adding a route back to 192.168.1.x at the edge... ( or were you perhaps NATTing in your previously working setup... either would resolve that issue )...

You have one interface called "internet", that is not mentioned on the firewall config. And you have a "wan" zone, that includes non-existing interfaces "wan" and "wan6". I think you just need to rename your "internet" interface to "wan".

1 Like

@eduperez Many thanks,it was that!
I (miserably) miss it even if I the firewall issue was my first thought :frowning:

okay, now the wifi AP... :smiley:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.