[SOLVED] "deauthenticated due to inactivity" after seconds

Hi all, I'm running the latest davidc502 build (7210) on a Linksys WRT32x. I'm seeing multiple clients on both the 2.4GHz and 5GHz radios frequently getting "deauthenticated due to inactivity". I appreciate that there is a real inactivity limit of 300s, but I'm regularly seeing clients get disconnected with this reason less than 30s after authenticating.

Example:

Fri Jun 29 14:01:36 2018 daemon.info hostapd: wlan1: STA 88:cb:87:d1:2f:7e IEEE 802.11: associated (aid 11)
Fri Jun 29 14:01:36 2018 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 88:cb:87:d1:2f:7e
Fri Jun 29 14:01:36 2018 daemon.info hostapd: wlan1: STA 88:cb:87:d1:2f:7e WPA: pairwise key handshake completed (RSN)
Fri Jun 29 14:01:36 2018 daemon.info hostapd: wlan1: STA 88:cb:87:d1:2f:7e IEEE 802.11: authenticated
Fri Jun 29 14:01:36 2018 daemon.info dnsmasq-dhcp[5401]: DHCPREQUEST(br-lan) 192.168.1.172 88:cb:87:d1:2f:7e
Fri Jun 29 14:01:36 2018 daemon.info dnsmasq-dhcp[5401]: DHCPACK(br-lan) 192.168.1.172 88:cb:87:d1:2f:7e Sallys-iPad
Fri Jun 29 14:01:36 2018 daemon.warn odhcpd[2374]: DHCPV6 CONFIRM IA_NA from 000100012257afb088cb87d12f7e on br-lan: not on-link 2001:470:1f09:df6::b7a/128 fd8d:9445:73f7::b7a/128
Fri Jun 29 14:01:36 2018 daemon.warn odhcpd[2374]: DHCPV6 SOLICIT IA_NA from 000100012257afb088cb87d12f7e on br-lan: ok 2001:470:1f09:df6::b7a/128 fd8d:9445:73f7::b7a/128
Fri Jun 29 14:01:38 2018 daemon.warn odhcpd[2374]: DHCPV6 REQUEST IA_NA from 000100012257afb088cb87d12f7e on br-lan: ok 2001:470:1f09:df6::b7a/128 fd8d:9445:73f7::b7a/128
Fri Jun 29 14:01:52 2018 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 88:cb:87:d1:2f:7e
Fri Jun 29 14:01:52 2018 daemon.info hostapd: wlan1: STA 88:cb:87:d1:2f:7e IEEE 802.11: disassociated
Fri Jun 29 14:01:52 2018 kern.debug kernel: [14945.216381] ieee80211 phy1: staid 11 deleted
Fri Jun 29 14:01:53 2018 daemon.info hostapd: wlan1: STA 88:cb:87:d1:2f:7e IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)

Authenticated and kicked off within 23 seconds...

Any bright ideas?

Add:

option disassoc_low_ack '0'

In your '/etc/config/wireless' under the 'wifi-iface' section

3 Likes

Thanks, that seems to have sorted it out

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

Ta, I'd been wondering if there was a mechanism to do that. Hadn't thought of such a simple solution :slight_smile:

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.