[SOLVED] DDNS detect LocalHost IP as WAN IP

dear all, i have an issue with DDNS service, it detect 127.0.0.1 instead of my wan ip adress


here is the log :

   135154       : #> /bin/uclient-fetch -q -O /var/run/ddns/noip.dat -4 -Y off 'User+Pwd@dynupdate.no-ip.com/nic/update?hostname=noipb.net&myip=WAN-IP' 2>/var/run/ddns/noip.err
 135155       : 'no-ip.com' answered:
nochg WAN-IP
 135155  info : Forced update successful - IP: 'WAN-IP' send
 135155       : Waiting 300 seconds (Check Interval)
 135655       : Detect registered/public IP
 135655  note : Busybox nslookup - no support to 'force IP Version' (ignored)
 135655       : #> /usr/bin/nslookup noipb.net  >/var/run/ddns/noip.dat 2>/var/run/ddns/noip.err
 135656       : Registered IP '127.0.0.1' detected
 135656  WARN : Updating IP at DDNS provider failed - starting retry 1/0
 135656       : Detect local IP on 'web'
 135656       : #> /bin/uclient-fetch -q -O /var/run/ddns/noip.dat -4 -Y off 'http://checkip.dyndns.com' 2>/var/run/ddns/noip.err
 135656       : Local IP 'WAN-IP' detected on web at 'http://checkip.dyndns.com'
 135656       : Update needed - L: 'WAN-IP' <> R: '127.0.0.1'
 135656       : parsing script '/usr/lib/ddns/update_no-ip_com.sh'
 135656       : sending dummy IP to 'no-ip.com'
 135656       : #> /bin/uclient-fetch -q -O /var/run/ddns/noip.dat -4 -Y off 'User+Pwd@dynupdate.no-ip.com/nic/update?hostname=noipb.net&myip=127.0.0.1' 2>/var/run/ddns/noip.err
 135658       : 'no-ip.com' answered:
nochg WAN-IP
 135659       : sending real IP to 'no-ip.com'
 135659       : #> /bin/uclient-fetch -q -O /var/run/ddns/noip.dat -4 -Y off 'User+Pwd@dynupdate.no-ip.com/nic/update?hostname=noipb.net&myip=WAN-IP' 2>/var/run/ddns/noip.err

Any Idea ?

Under advanced...which Network [IPv4] do you have selected???

Untitled1
i change the default http://checkip.dyndns.com to verify but always same issue .
For information i have a DSL MODEM working on 192.168.0.1 with no dhcp and my router have LAN working on 192.168.1.1 and my wan interface on static ip : 192.168.0.2 with Gateway 192.168.0.1
no other change are made of default settings.

hi, i think i found solution not sure yet, but however, it seem to be a bug on the script that support NO-IP,
after reading the script, i see that they contain a function like "sending dummy ip to no-ip" and the dummy ip is 127.0.0.1 on the script !!!
i just come back to setting and using custom provider, then using this url : # http://[USERNAME]:[PASSWORD]@dynupdate.no-ip.com/nic/update?hostname=[DOMAIN]&myip=[IP] #
for now it work perfectly, i will confirm after 24h if the bug comes from the no-ip script.

Could you please tell me how you did the setup for no-ip using custom provider as i am having issues when the PPPOE session changes IP the DDNS doesn't update at all it is still stuck with the old IP even after stopping and starting the PID.

Thanks in advance.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.