[Solved] Configuring DSL with static IP address (ETHoA)


First of all, I am new to OpenWRT so will be thankful for any ideas :slight_smile:

I have TP-LINK TD-W8980 (has DSL modem) with OpenWrt 18.06.2 and am trying to make ADSL2+ connection with static IP address..

Settings from my previous (not OpenWRT router):

Technology: DSL
Protocol: ETHoA
Mode: ADSL2+
Type: Interleaved
Line Coding: Trellis on
Status: No defect
Link Power State: L0
VPI: 8
VCI: 35
Encapsulation: LLC
Connection type: Routed Ethernet Connection Over ATM (ETHoA)
IP address/netmask/gw are set manually.. There are no username/pass for PPPoE..

Any suggestions how to set up this on OpenWRT?

Thank you in advance


Actually it was easier than I expected.. :slight_smile:

First of all, I added ATM bridge using settings which I new from my old router (VPI, VCI, ..).. Then I noticed that there were no DSL settings available in LuCi.. They appeared when I edited /etc/config/network and added:

config dsl 'dsl'

with some options..

Then I noticed that my DSL status is actually UP and I get dev dsl0 created.. LuCi let me create WAN interface based on dev dsl0 and set static IP address.. Unfortunately, no connection.. :frowning: Then I noticed that Link encap: of dev dsl0 is PPP.. After changing Forwarding mode from Routed to Bridged in ATM bridge Advanced settings, dsl0 Link encap: became Ethernet and everything started to work! :wink:

My working config:

config atm-bridge
	option unit '0'
	option atmdev '0'
	option encaps 'llc'
	option vci '35'
	option vpi '8'
	option nameprefix 'dsl'
	option payload 'bridged'

config dsl 'dsl'
	option xfer_mode 'atm'
	option line_mode 'adsl'
	option ds_snr_offset '0'
	option annex 'a2p'

I am really happy with my OpenWRT router now :slight_smile:

If you got it fixed mark the topic as solved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.