[SOLVED] Can't enable Energy Efficient Ethernet EEE 802.3az on AR8327

Hey all,

I have a Meraki MX60W with an Atheros switch.

I know that the downstream switch on port 1 is capable of Energy Efficient Ethernet

Port 1:
	mib: MIB counters
RxBroad     : 32
RxPause     : 0
RxMulti     : 308
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 300
Rx128Byte   : 5750
Rx256Byte   : 1180
Rx512Byte   : 102
Rx1024Byte  : 679
Rx1518Byte  : 957
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 2375552 (2.2 MiB)
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 3
TxBroad     : 15
TxPause     : 0
TxMulti     : 93
TxUnderRun  : 0
Tx64Byte    : 129
Tx128Byte   : 5498
Tx256Byte   : 1015
Tx512Byte   : 291
Tx1024Byte  : 669
Tx1518Byte  : 635
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 1898013 (1.8 MiB)
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	enable_eee: 0
	igmp_snooping: 0
	pvid: 1
	link: port:1 link:up speed:1000baseT full-duplex txflow rxflow eee100 eee1000 auto

I've tried both commands below, and neither change enable_eee to 1 under swconfig:

config switch_port
	option name 'switch0'
	option port '1'
	option enable_eee '1'

and

config switch_port
	option port '4'
	option enable_eee '1'

Any ideas?

I found the solution:

https://openwrt.org/docs/guide-user/base-system/basic-networking

THE DOCUMENTATION IS WRONG:

name string yes (none) defines which switch to configure

This attribute is NOT name, it's DEVICE:

	enable_eee: 1
	igmp_snooping: 0
	pvid: 1
	link: port:1 link:up speed:1000baseT full-duplex txflow rxflow eee100 eee1000 auto

config switch_port
option device 'switch0'
option port '1'
option enable_eee '1'

1 Like

Thank you!

That also solved my problem of not being able to set PVIDs on the switch. With the correct option or syntax, it works. Well, I also locked myself out of my device now testing this, but that was my own fault :wink:

1 Like

How can you check if the switch is capable?

swconfig dev switch0 help

You should see a line under - -port that says:

Attribute 3 (int): enable_eee (Enable EEE PHY sleep mode)

To check the device connected to the switch:

swconfig dev switch0 show

On the port, you will see eee100 and/or eee1000

link: port:1 link:up speed:1000baseT full-duplex txflow rxflow eee100 eee1000 auto

1 Like

I updated the switch_vlan and switch_port documentation in the wiki, so hopefully nobody else stumbles over this.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.