[solved] Can't change router IP and DHCP range

I have a Linksys WRT1200AC running OpenWrt 21.02.1. I haven't been able to change the router's IP address and the DHCP range. I want the router IP address, and the DHCP range to be to But when I try to make those changes, the router keeps going back to default and 192.168.1.x IP range. I've tried hitting apply save and save and apply, as well as hard rebooting after saving and applying.

My changes, starting with a default openwrt router:
Network > Interfaces > LAN [edit]
IPv4 address changed from default <> to <>
Under DHCP Tab > General Setup, changed Start to 9 and Limit to 230.
Here's screen shot (nope, can't post images)

After making those changes, I hit save and then save and apply, I get this countdown.
[edit] can't post images, ugh!

"applying configuration changes..."
When the count down completes, I get the
"Failed to confirm apply within 90s, waiting for roll back"

I noticed my computer's network interface disconnect and reconnect, but doing ipconfig shows I still have the old 192.168.1.x IP address, and the router is still at instead of

Edit: It's so confusing. The web interface, after I go back to accessing it on, still shows the edits. It's like it retains the changes I wanted to make, but is not using the configuration that's being shown on the UI. It's using the configuration that was previously there, now no longer shown.

Try just changing the LAN IP address to in first instance.

If you can't complete this step in LuCI because of the Rollback prompts not working properly (I come across this issue frequently and it is frustrating), SSH into the router and execute the following commands to force the change through:

uci set network.lan.ipaddr=''
uci commit
/etc/init.d/network restart

Then change the DHCP range.

Finally change the LAN IP to

1 Like

Thanks, I think I finally got it to stick. I had to hard-reboot after applying, even though DHCP was providing the correct new IP and showing the correct gateway address, I couldn't ping router or get web UI up until after reboot.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.