[SOLVED] Cannot run rtl_tcp detached from Local Startup (/etc/rc.local)

Hello all,

I have a Software Defined Radio dongle that I'm attempting to run on my router with a USB port (see: Software Defined Radio on LEDE). The rtl-sdr software and its dependencies install and run just fine on the device; but the issue is with auto startup upon boot. I'm unable to run the userspace program from the Local Startup (/etc/rc.local). Although, if I run the command via the Custom Firewall Script or via the Command Line, it works:

rtl_tcp -a 192.168.xxx.xxx

I've also tried:

rtl_tcp -a 192.168.xxx.xxx &

I've also made a sh script and attempted to run that from /etc/rc.local instead.

Any ideas on how to fix this, or another location to place the command?

Firewall is not a good location, as a bad instance of the program loads to memory each time FW3 is restarted).

Why not write you own script in /etc/init.d/?

Wow...I just realized a script exists and must have been installed with rtl-sdr...but it doesn't run either....

I gave up on /etc/rc.local quickly for a task I needed to run recently (March, 2018, master branch), as it never ran. Executable bit was set and was root readable and executable.

Looks like a bug in the start-up process.

Looks like /etc/rc.local should have been executed by /etc/init.d/done so puzzling as to why it wasn't run

        # process user commands
        [ -f /etc/rc.local ] && {
                sh /etc/rc.local

I found the solution.

rtl-sdr is incorporated into UCI!!! The config file is located at /etc/config/rtl_tcp!!!

Changed option disable to 0 and added a listen IP address!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.