[Solved] Cannot open 3389 port

Hi, cannot open 3389 port. TP-Link 841ND v8, latest 15.05.1. With doing same for 80 (Traffic rules -> Open port and set Port forwarding) - can open and forward 80 port. For 3389 - no chance, even accept all in zone settings. What I'm doing wrong?


I assume you understand the difference between port opening and port forwarding.
And if you use port forwarding, make sure that firewall is configured correctly on the destination host.

ofcourse i'm not a pro in networking, but.. yep. before this router i'd used day ago 740n with stock with forwarding 3389, so i could access remotely my home laptop from my job
i didn't remember, probably in stock ports are opened at all.

so i think that may be present in openwrt any setting for blocking all "unsafe" ports, like 3389. because if i've allowed in zones i thought all - only 3 ports opened - 22,80 and forgot some one.

In that case remove port opening rule and add port forwarding.

Let me be clear...the rule above in Post No. 1 for port 80 is unsafe - as it opened your router to WAN. To be clear: THAT WAS NOT A FORWARD RULE TO A SERVER, IT IS AN INPUT RULE TO THE ROUTER'S WEB GUI. If your WAN has a Public IP address this is extremely dangerous.

Are you trying to open ports to the router?

Because, as @vgaetera said:

Port 22:

Someone could Brute Force the router via SSH without additional safeguards (e.g. using key-only login to the router's SSH port).

1 Like

ok, as i understand - i don't need to open this ports, just to forward'em. but when i've just forwarded 3389 and couldn't connect to my, so decided that i need to open

well, that question is - why forwarding 3389 is not work :confused:

i just need connect remote desktop. 80 port i've opened for reason to test of forwarding work or not

You don't need to open them on OpenWrt, just to forward.
But you still need to open them on the destination host.

1 Like

Thanks for help :slight_smile: Have removed port opening, have left only forwarding rule for 3389 and.. solution was so simply =) When i changed router - network changed from private to public. So RD connection rejects. So i've changed to private and all now fine )

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.