[Solved by doing a reset] "Set static" for LAN device now no access to WAN

I've got a Belkin RT 3200 with OpenWrt 22.03-SNAPSHOT, r19338-ae64d0624c installed. Suddenly I have no WAN connection.

I have a little server running and I clicked the "Set static" button in LuCI to prevent its IP address from changing. That's the only change I've made to the settings recently. Now none of my devices can reach the WAN and I can't ping from the router. Everything seemed fine for a short while after setting the static IP though so that may not be the issue.

I've plugged in the old router provided by my ISP and that's working fine. Where should I look to start fixing it? It's a bit tricky because I have to keep switching routers to do it.

For testing just daisy chain the routers e.g. connect LAN ISP to WAN of the RT3200.

The only thing you have to pay attention to is that the RT3200's IP address (subnet) is different from the ISP router.


Go to Network > DHCP and DNS > Static Leases
and delete the device you added by "set static". Save and apply.
But I doubt this will solve your WAN issue.

Thanks for the replies. I already removed the static lease and that hasn't fixed it.

Both routers were using so I tried changing the Belkin to Changing the subnet in LuCI it just ends with "Failed to confirm apply within 90s, waiting for rollback…" and no changes. After following the cli instructions I'm now getting "No route to host" when I SSH using either the old or new IP address.

I've got myself even more stuck than I was before!

1 Like

yes, it'll roll back the IP change.
isolate the Belkin and logon again, then redo.
use apply unchecked.


1 Like

Thanks. I can now access the Belkin via the new IP but I can't figure out which way to connect things to access the Belkin and the internet at the same time. I've tried all of the combinations of connections between the two routers and the PC I can think of.

Edit to clarify, I have a TP-Link Archer VR400 in bridge mode acting as a modem. The Belkin is (was) working as the router. I left out the Archer when trying to connect the Belkin with the ISP modem/router.

Edit again: I gave in and pressed the "Reset" button. Everything seems to be fine again and I'll just have to put my settings back how they were. Still don't know what the problem was so I may be back if it happens again!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.