[Solved] Bug - 2nd an 4th SSID on LuCI Wireless shows SSID name No. 4?

I have the following SSIDs on a 2.4 ath9k in LuCI:

  • w (enabled)
  • x (disabled)
  • y (disabled)

I added SSID z and the following displayed:

  • w (enabled)
  • 'z' (disabled) with the name (but it is actually x!!!)
  • y (disabled)
  • z (enabled)

Any ideas?

hapened something similar to me with 17.01.4 when having disabled's SSID... just enable it all again and the problem will go away! :smile:

Thanks @braian87b. I enabled SSID x and the name changed...then SSID y exhibited the same problem. Enabling all SSIDs solved the problem!

Thanks...(although it does appear to be a bug regarding how the disabled wireless interfaces are displayed on screen).

Yes this is a known bug which already has been fixed in LuCI master. See https://github.com/openwrt/luci/issues/1179 .


As I'm running 17.01.4....is this update expected in the next release?