[Solved][Buffalo WZR-HP-AG300H] Dead Router when upgrading from OpenWRT 15.05.1 to LEDE 17.01.0

Hello LEDE Project!

I wanted to report my findings of attempting a sysupgrade via Luci from OpenWRT 15.05.1 to the latest stable LEDE release of 17.01.0.

In short, it failed.

The upgrade completed, all of my red lights stopped blinking, but no Luci interface would come up. I checked my ethernet connection and my computer was getting a connection to the 192.168.11.X subnet. Which I thought was odd, considering that the default address is supposed to be connected to the 192.168.1.X subnet.

So, I went about attempting to pull up My Chromium browser (on Ubuntu here) spun for a second or two, but then came back telling me it couldn't load anything at that address.

I tried pinging both and The former gave me "network unreachable" (which makes sense considering my netmask and being on the 192.168.11.X network), and the latter gave "destination unreachable", as the router was not responding to PING packets at all.

Luckily, my cell phone does hotspotting, so I setup a temp network, downloaded the old OpenWRT 15.05.1 TFTP package, and follow these guides:

  1. https://wiki.openwrt.org/doc/howto/generic.flashing.tftp#linuxbsd
  2. https://wiki.openwrt.org/toh/buffalo/wzr-hp-ag300h?s[]=ag300h

And boom! I'm back up and running on a "fresh" install of OpenWRT.

Now What?

So, since an apparent sysupgrade (for which I verified the SHA sums and MD5 sum manually, since OpenWRT provides MD5 sums when uploading new firmware) failed from Luci with this release, what do I do next? Do I try a TFTP flash? Wait for a possible fix of the sysupgrade image? Or go ahead and try this mess again?


Flashing the TFTP image worked. I'm not sure what happened with the sysupgrade, but using the same method I linked above to flash to the TFTP image of LEDE worked quite well.

Out of curiosity, did you wipe your settings when performing the sysupgrade?

Yes, I specifically had to go back to the flash page and ensure that my settings were wiped, as I noticed that they were being preserved when I was verifying the MD5 of the new image.