SOLVED: BT Home Hub 5A snapshot

I have an eBay Home Hub 5a with 17.01.3 pre-installed, it worked fine on BT Infinity with a dummy, not null, password.

I updated it with Thursday's lede-lantiq-xrx200-BTHOMEHUBV5A-squashfs-sysupgrade and installed LuCI and it still worked fine. I'm fairly sure I rebooted to check it could do that after LuCI was put back.

Then I ignorantly and injudiciously plugged a USB2 memory stick in the back of the router.

There was an instant reboot. The router came back and still works but with two exceptions.

Firstly, I can no longer ssh into it as root and I've not added any other username. ssh says the connection is refused.

Secondly, LuCI no longer reaches a login page. It can see the router but gets a 404 error when just using the IP address.

I'm not sure how to get in to make corrections or how to revert anything. Would anyone like to direct me?

It's gone away - both those problems have just disappeared. Another reboot appears to have mended matters. I can now ssh, and the LuCI screen is back in place.

I shall look at an expert page on what I might do to get the USB slot active. perhaps.

A device should never reboot when inserting a USB stick (or generic device) or any kind. The most likely reason for that would be poor grounding or something else allowing static electricity to affect the running router, this would be a hardware deficiency (and is probably unfixable, in which case I'd suggest not using the USB ports, at least not while the router is powered on). If your router is indeed susceptive to static electricity charges from the USB port, a lot could have happened - from temporary hickups of the running system, to data corruption on the flash image up to permanent hardware damage. In order to rule out flash corruption, I'd reflash (sysupgrade) the router with the same or a newer LEDE version just to be sure - at least if you continue to observe weird behaviour.


I've noticed the exact same issue. From my experience, what seems to happen is when a USB device that does not have a driver is inserted, the Homehub first restarts, and then often, refuses to boot at all.

Now having read about your experience, I will need to test my HH5 for any messages on the serial port - I'm guessing yours came from the guys at Wireless Freedom and doesn't have serial leads?

I suggest this bad behaviour has nothing to do with earthing or over-current on the Vbus controller, as I've faulted my own HH5 by plugging into the port on a self-powered USB Hub.

I suspect there is something freakish with the USB OTG root hub controller - just putting that out there, anyone?

I'll check, but I think I have the full set of kmod-usb modules installed - including the USB storage support.

Using 17.01.04

Andy B

For anyone playing at home, here is my script for installing USB support:

opkg update
opkg install kmod-usb-ohci
opkg install kmod-usb-uhci
opkg install kmod-usb2
opkg install usbutils
opkg install kmod-usb-storage-extras
opkg install kmod-usb-test
opkg install kmod-usb-storage
opkg install kmod-fs-ext4
opkg install kmod-fs-vfat
opkg install block-mount


Yes that's the retailer.

The additional installs makes a lot of sense, I've added those now.

I'm pleased with the revamp of my BT router - I have a supplied Hub6 which I can always fall back on if things go pear-shaped. My immediate observation is that my signal strength punches through walls a lot better than the original.

I have experience with openwrt but not beyond newbie playing. Linux, yes, but not often in so small a space.


just spent lunchtime hot-plugging a number of different USB devices in and out of a HH5A with LEDE 17.01.03 - memory sticks, bluetooth dongles, 3G dongles, mice, hubs, card readers, etc > basically anything I could find. And yes, the Homehub 5 does seem to exhibit a strange reboot reflex with certain USB devices. Even when there is an driver installed, some devices forced the Kernel to collapse!

SLH is right,

A device should never reboot when inserting a USB stick (or generic device) or any kind

This is certainly worth investigating. I will first need first check the console output and the USB device descriptors in /sys/bus/usb/devices/

If there is anyone else who has experienced similar USB problems with the BT Homehub 5, or any other routers with the Lantiq XRX200 chipset, then please let us know.

With regard to your Wifi, I find the 2.4GHz radio is strong and stable, but the 5GHz radio can be a touch flakey when out of line-of-sight. But then that's microwaves - they don't like going through solid walls or wet things, like people. With the Lede Hub it's nice to have the ability to alter the power and bandwidth - and use uncrowded channels. Meanwhile, BTs recent claim that their SmartHub 6 has the most powerfull Wifi signal ever is misleading. It's possibly the strongest that's legal in the UK, but no more dBm's than any other router. Remember the ad where the guy is receiveing Wifi in a helicopter? That's just BAD aerial design. Good signal propagation goes sideways, not upwards - unless you're bouncing your Wifi off the Ionosphere!

Interesting: Maximum Wifi Transmission Power per Country

I've just had a look at the console whilst plugging in various USB devices, and managed to get one USB device to fault the Homehub. All that happens is the Kernel reports on finding the new USB device - as normal - and then goes into feak mode, rebooting dozens of times over before stabilising.

[ 4665.193006] usb 1-1.1: new full-speed USB device number 11 using dwc2
ROM VER: 1.1.4
CFG 06
This repeats over 50 times!
Eventually the bootlog reports...
[ 5.977007] usb 1-1.4: new high-speed USB device number 3 using
[ 6.297007] random: nonblocking pool is initialized
[ 8.941235] UBIFS (ubi0:2): background thread "ubifs_bgt0_2" started, PID 397
[ 8.969055] UBIFS (ubi0:2): recovery needed
[ 9.127781] UBIFS (ubi0:2): recovery completed

I'll have to do a deep compare between a normal bootlog and our USB inspired re-bootlog.

Earlier I noted one USB Device reported

[ 4193.036998] usb 1-1: new full-speed USB device number 6 using dwc2
[ 4193.237156] usb usb1: clear tt 1 (8060) error -22
[ 4193.240541] usb usb1: clear tt 1 (8060) error -22
[ 4193.245632] usb usb1: clear tt 1 (8060) error -22
[ 4193.250175] usb usb1: clear tt 1 (8060) error -22
[ 4193.254874] usb usb1: clear tt 1 (8060) error -22
[ 4193.259971] usb usb1: clear tt 1 (8060) error -22
[ 4193.264286] usb usb1: clear tt 1 (8060) error -22
[ 4193.269035] usb usb1: clear tt 1 (8060) error -22
[ 4193.273771] usb 1-1: device descriptor read/all, error -71
[ 4193.279357] usb usb1: clear tt 1 (8060) error -22
[ 4193.460995] usb 1-1: new full-speed USB device number 7 using dwc2

Note it was allocated device 6 then becomes 7. Freaky.

Andy B

This may be inconsequential but the stick which crashed the router had an unlikely partition table, it was W95 FAT. My bootlog for the event has been superseded.

The tail of my current kernel log notes that I reformatted the same stick as 1G swap and 7G ext4, there's just one warning and I've not tried eliminating that yet.

[86506.966311]  sda: sda1
[86506.979774] sd 0:0:0:0: [sda] Attached SCSI removable disk
[86752.271442]  sda:
[86873.678165]  sda: sda1 sda2
[86910.270491] Adding 1048572k swap on /dev/sda1.  Priority:-1 extents:1 across:1048572k 
[87556.546071] EXT4-fs (sda2): couldn't mount as ext3 due to feature incompatibilities
[87556.557553] EXT4-fs (sda2): couldn't mount as ext2 due to feature incompatibilities
[87556.594376] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)
[111556.100651] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[111556.115746] ohci-platform: OHCI generic platform driver
[111561.959290] uhci_hcd: USB Universal Host Controller Interface driver
[111568.634492] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[111568.639749] Warning! ehci_hcd should always be loaded before uhci_hcd and ohci_hcd, not after
[111568.759132] ehci-platform: EHCI generic platform driver


From my test the log read

[    9.407414] SCSI subsystem initialized
[    9.427152] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    9.433873] ehci-platform: EHCI generic platform driver
[    9.445304] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    9.451576] ohci-platform: OHCI generic platform driver
[    9.461262] uhci_hcd: USB Universal Host Controller Interface driver
[    9.476896] usbcore: registered new interface driver usb-storage

So that's in the order required, by default. I'm not a Linux supergeek, so I'd not know why it's different in your case.

I think at the moment with this USB glitch, there's too many unknowns. I faulted the HH5A with a memory stick and now it's working okay!! I am wondering if there is something more fundimental going on here with the HH5s design? Is there a bus sync issue or a power sag when a new device is added? Not having a circuit diagram means it's just speculation. I cannot find any other similar issues with other routers using Lantiq XRX200 chipsets.

One point to note is the USB port on the HH5s ( and HH4 & HH6 ) have never been used for anything more than a network memory stick for Windows. It would have been nice to have used it as a network print port - but BT's original firmware was just too nasty to even go there.

Andy B