[Solved] Baud rate of Aztech HW550-3G

Hello World,

I want to install OpenWRT in an Aztech HW550-3G. Using following link, i found connections for Serial.


As per above, i connected :
1st pin from top, Vcc : Not connected to serial
2nd pin from top TX : Serial pin 2 RX
3rd pin from top RS : Serial pin 3 TX
4th pin from top GND : Serial pin 5 GND

This is the USB to Serial convertor I am using. Remove underscore at the end.


Now the problem is that when i connect with putty with the given settings on above page, it is giving garbled output.

I have tried all the standard baud rates and even tried some non-standard ones but couldnt figure out.


Ammar Ahmed

  • How bout flow control?
  • Also, ensure that your pins are not reversed.

As per openwrt wiki, i used none, but let me give it a quick try with other options.


Just tried all the options of flow control and none of them worked for me.



Disconnect all three wire from the device.
Then join the TX and RX wires only together
Leave all other wires disconnected.

From putty use the expected setting for the device.

Then start typing.

You should see everything you type echoed back at you in putty.

If you don't your serial cable may be faulty.

Guys, that's not a TTL adapter...

1 Like

WOW!!! Good catch!!!

You need a RS-232 5 Volt-to-TTL 3 Volt serial downconverter!

That device is probably damaged beyond repair by now.

Just save yourself the trouble and get yourself a proper adapter and some dupont cables...

I'd highly recommend this guy, genuine FTDI (beware of fake FTDI chips (RT232R / RT232RL primarily), please don't support such actions) and very good build quality.

Cheaper device but you don't probably notice a difference if you're just doing TTL, CP2012 made by Siicon Labs and being dirt cheap it doesn't have any known fakes around (afaik).

Prolific are also around, avoid PL2303HX(D) since it's EOL and known to have lots of fakes around. PL2303TA is a more safe option but you can probably find fakes of that one too I'd guess.

CP2012/13/14 are probably the only TTL adapters (chips) I'd consider safe to get off Aliexpress if you're going that route.

DKU-5, CA-42 are all TTL cables... :slight_smile:

OK , must have misread the details

Yup, i have made that sure many times.

Damn it, either i need Max232 IC (which i really dont want) or actual USB to TTL (which means waiting of a month). But if any of you is aware of RS232 to TTL with MAX232 IC, let me know.

I agree with all 3 of you. Damn i ordered PICKIT2 and USBASP last week but thought this shit RS232 will work :(, already it tried to f**k my laptop while i tried it for a PIC JDM Programmer, i think this should be the end of it.

My actual goal is to run this router with a USB RNDIS Wimax device. And original firmware does not seems to support RNDIS.


Anyways, many thanks all of you, i am suspending this project until i get a USB to TTL.

Ammar Ahmed

1 Like

https://www.ebay.com/itm/TTL-RS-232-Serial-Adapter-Module-COM-MAX-232-CPE-Table-Chip-Wall-Sticker/182696818157?epid=890121923&hash=item2a899435ed%3Ag%3ADIQAAOSwSplZgGbw&_sacat=0&_nkw=max232&_from=R40&rt=nc&_trksid=m570.l1313 etc

I would however do some research as I wouldn't be surprised if you can find fake ones around unfortunately since the chip itself seems to be around 2-3$ or so.

SPIEX is another brand that offers cheaper controllers and are probably also more "safe" as they are not as widely known...


As you can tell however, if you want something cheap the CP210* is a better choice and cheaper in the end. These are also available on Amazon etc

@diizzy Hint to shorten aliexpress urls substantially: In general you can omit everything after the ".html".

This seems to be a work around. I may retry it on PIC JDM Programmer. Lol, just seeing if it is diy doable. Damn external 5 volts and 5 extra 1uF capacitors :scream: are what is bothering me.


It's been many years since my circuity class....but...it DOES NOT appear the diagram asks you to connect a 5V supply, as the arrow is pointing OUTWARD.

It appears that there will be +5V on pin 16, and you have to attach 16 to a 1uF capacitor to pin 2 and another capacitor, and attach to Ground.

You need 3.3V ,that is a bad diagram

A better DIY explanation Here


Special thanks to diizzy who pointed me in the right direction.

After a bit of patience and keeping my brain busy in other projects (Pic and AVR). I went to local store and bought MAX232 IC (It was sunday so i couldnt buy PIC ic and USBasp wasnt working for me). With the same schematics I mentioned above, IT WORKED. We can call this SOLVED.

Sorry guys, how can I mark it Solved ?


1 Like
  • Mark @diizzy's post as the solution
  • Edit the title and append [SOLVED] to the beginning

Glad you got it working.

1 Like

@nocammar How to do that:



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.