[SOLVED] Backport mac80211 compile error


#1

make package/mac80211/{clean,compile} V=s

only shows this as hint:

ERROR: module '/home/drbrains/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7621/backports-4.19-rc5-1/net/mac80211/mac80211.ko' is missing.

Its not indicating "Why" it failed to compile or create the required folders. The only folder before this error is:

mkdir -p /home/drbrains/openwrt/bin/targets/ramips/mt7621/packages /home/drbrains/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7621/backports-4.19-rc5-1/ipkg-mipsel_24kc/kmod-mac80211/CONTROL /home/drbrains/openwrt/staging_dir/target-mipsel_24kc_musl/pkginfo

Dev builds brick my DIR-860 B1
#2

Please place all code, config, and log output within code blocks... three ways to do so


#3

Post modified; on personal note I don't think that actually enhances readability.


MT76x02 Kernel Panic
#4

Code, config, and log output are monospaced text, and normal fonts are not, which makes reading monospaced output that's non-monospaced cumbersome and more difficult for those trying to help, as it requires them to attempt to parse where one line ends and another begins due to word wrap. Additionally, after ~20 lines, a code box will scroll, versus having one long post.


#5

Got it!

As for the actual problem... non of the code inside the mac80211 folder is getting compiled. So obviously no .ko file is generated. At first glance I couldn't see anything wrong with the Makefile or the Kconfig.


#6

After a complete clean setup I can't reproduce the problem. I normally copy the downloaded files over to a new build-setup. I had it download all the packaged again (which shouldn't matter, it did somehow).

Marked: SOLVED


#7

Often a make clean of the buildroot will fix most compilation issues, especially if building for more that one device model