Solved : Automount / hotplug NTFS

I have build 2102.rc4 Tenbay AX1800 and i cannot automount USB hdd

Tenbay exist only in snapshots

root@OpenWrt:/etc/hotplug.d/block# blkid
/dev/sda1: LABEL="500GB" BLOCK_SIZE="512" UUID="02523648523640A9" TYPE="ntfs" PARTUUID="2749c516-01"
ls /mnt/sda1 -> nothing

for find HDD files i run ntfs-3g /dev/sda1 /mnt/sda1 and files are there

problem is also after when i unplug & plug i have:after

root@OpenWrt:/# blkid
/dev/sda1: LABEL="500GB" BLOCK_SIZE="512" UUID="02523648523640A9" TYPE="ntfs" PARTUUID="2749c516-01"

ntfs-3g /dev/sda1 /mnt/sda1
ntfs-3g-mount: failed to access mountpoint /mnt/sda1: No such file or directory

with old WR1200JS or MiWIFI-D2 i have not this problem
I have build with same PKG options

opkg install  attr avahi-dbus-daemon base-files blkid block-mount busybox 
opkg install   ca-bundle cgi-io dbus dnsmasq dropbear e2freefrag e2fsprogs firewall fstools 
opkg install  fwtool getrandom hd-idle hostapd-common ip6tables iperf3 iptables iw iwinfo 
opkg install  jshn jsonfilter kernel kmod-cfg80211 kmod-crypto-crc32c kmod-crypto-hash 
opkg install  kmod-fs-exfat kmod-fs-ext4 kmod-fs-msdos kmod-fs-reiserfs kmod-fs-vfat
opkg install   kmod-fuse kmod-gpio-button-hotplug kmod-ip6tables kmod-ipt-conntrack kmod-ipt-core 
opkg install  kmod-ipt-nat kmod-ipt-offload kmod-leds-gpio kmod-lib-crc-ccitt kmod-lib-crc16
opkg install   kmod-mac80211 kmod-mt76-core kmod-mt7603 kmod-mt76x02-common kmod-mt76x2
opkg install   kmod-mt76x2-common kmod-nf-conntrack kmod-nf-conntrack6 kmod-nf-flow kmod-nf-ipt 
opkg install  kmod-nf-ipt6 kmod-nf-nat kmod-nf-reject kmod-nf-reject6 kmod-nls-base kmod-nls-cp437 
opkg install  kmod-nls-iso8859-1 kmod-nls-utf8 kmod-ppp kmod-pppoe kmod-pppox kmod-scsi-core 
opkg install  kmod-slhc kmod-usb-core kmod-usb-ehci kmod-usb-ledtrig-usbport kmod-usb-storage
opkg install   kmod-usb-storage-extras kmod-usb-storage-uas kmod-usb-uhci kmod-usb-wdm kmod-usb2 
opkg install  kmod-usb3 libatomic1 libattr libavahi-client libavahi-dbus-support libblkid1
opkg install   libblobmsg-json20210516 libbz21.0 libc libcap libcomerr0 libdaemon libdbus 
opkg install  libexif libexpat libext2fs2 libffmpeg-audio-dec libflac libgcc1 libgmp10 libgnutls 
opkg install  libid3tag libip4tc2 libip6tc2 libiwinfo-lua libiwinfo20210106 libjpeg-turbo 
opkg install  libjson-c5 libjson-script20210516 liblua5.1.5 liblucihttp-lua liblucihttp0 
opkg install  libncurses6 libnettle8 libnl-tiny1 libogg0 libopenssl1.1 libpopt0 
opkg install  libpthread libreadline8 librt libsqlite30 libss2 libtasn1 libtirpc libubox20210516 
opkg install  libubus-lua libubus20210603 libuci20130104 libuclient20201210 liburing 
opkg install  libustream-wolfssl20201210 libuuid1 libvorbis libwolfssl4.7.0.66253b90 
opkg install  libxtables12 logd lua luci luci-app-firewall luci-app-hd-idle luci-app-minidlna
opkg install   luci-app-opkg luci-app-p910nd luci-app-samba4 luci-base luci-compat 
opkg install  luci-lib-base luci-lib-ip luci-lib-jsonc luci-lib-nixio luci-mod-admin-full 
opkg install  luci-mod-network luci-mod-status luci-mod-system luci-proto-ipv6 luci-proto-ppp 
opkg install  luci-proto-relay luci-theme-bootstrap luci-theme-material minidlna mtd netifd
opkg install   ntfs-3g odhcp6c odhcpd-ipv6only openwrt-keyring opkg p910nd ppp ppp-mod-pppoe 
opkg install  procd relayd rpcd rpcd-mod-file rpcd-mod-iwinfo rpcd-mod-luci rpcd-mod-rrdns 
opkg install  samba4-libs samba4-server terminfo ubi-utils ubox ubus ubusd uci uclient-fetch 
opkg install  uhttpd uhttpd-mod-ubus urandom-seed urngd usign wireless-regdb wpad-basic-wolfssl wsdd2 zlib

```**strong text**

checked the permissions of that dir ?

With automount, then the directory should be created and removed automatically.
Otherwise, create it manually, and you can use another directory:

mkdir -p /mnt/data

solved with

ln -s /usr/bin/ntfs-3g /sbin/mount.ntfs

very old bug -> 2006

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.