[Solved] AT&T Nighthawk LTE Mobile Hotspot Router (aka Netgear MR1100)

I have Used different Netgear hotspots in last couple of years. Recently bought this new hotspot and it works fine in Ubuntu 18.04 and Windows as RNDIS device. However, my current setup of Openwrt/Lede 17.01.4 does not detect it as a RNDIS device. Same current setup of Openwrt works fine with other RNDIS compatible model AT&T Unite Explore (aka Netgear AC815S)

Below are the links of the products page.

MR1100 product info. - https://www.netgear.com/images/InstallationGuide/mobile/MR1100ATT/MR1100ATT-USERS-MANUAL.pdf

AC815S product info. - https://www.netgear.com/support/product/AC815S.aspx#docs

I have found one post in Netgear forum informing that this new device has differnt port configuration which confuses linux based system probably for specific kernel (but works fine for me on ubuntu 18.04)

below is the link of the solution on how to manually fix bConfigurationValue so that the linux OS will detect it as CDC Ether device.

I tried to achieve same solution in Openwrt but found no success in changing the bConfigurationValue

So I am currently stuck in using Ubuntu 18.04 to share Internet from this hotspot. I will greatly appreciate if someone will help me find out the easy solution to this problem. Thank You.

Well no response from anyone so I tried version 18.06 rc1 and problem resolved. Working now.

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)