[SOLVED] Assistance with Network Interfaces

Hi,

I'd be grateful of some assistance with configuring my network interfaces.

I've a Linksys WRT1900ACS that I updated to OpenWRT dc502 community build (r9886) today and I restored my settings from my older LEDE setup.

I switched ISP recently and simply disabled the old PPPoE interface but somehow on restoring components of it have been merge into the WAN interface.

I discovered a problem attempting to add a user account as I was unable to opkg update as wget errored out with 4. I had a read around and found a few mentions that this may be down to IPv6 in some manner but I can't figure out what to do and would be grateful of some advice.

I've also found that trying to connect to something like http://bbcmedia.ic.llnwd.net/stream/bbcmedia_6music_mf_p from mpd times out now. Before the upgrade it worked fine and it works from a browser.

Further my phones and tablets are connected to the WiFi network but can't access the internet from any application.

My current /etc/config/network is as follows...

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdee:e2bd:86fe::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1'
	option _orig_ifname 'eth1'
	option _orig_bridge 'false'
	option proto 'pppoe'
	option username '########'
	option password '########'
	option mtu '1480'
 	option keepalive '0'
	option ipv6 'auto'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6'

config interface 'Zen'
	option proto 'pppoe'
	option ifname 'eth1'
	option username '#########'
	option password '#########'
	option ipv6 'auto'
	option mtu '1500'
	option peerdns '0'

config interface 'WAN4'
	option proto 'dhcp'
	option ifname 'eth1'

Zen is my current ISP so I know I need that, PPPoE I also understand I need some of LAN, WAN and WAN6, but am really confused as to which I can get rid off without screwing things up.

Any advice would be gratefully received, thank you in advance.

All of those symptoms result from simply having no connection to the Internet.

Remove the "Zen" and "WAN4" that you added and concentrate on configuring "wan" properly for a pppoe connection. "wan6" can also be removed-- in the case your ISP supports IPv6 it would be handled in the regular wan.

Critical to the troubleshooting is using logread to observe the logs.

1 Like

Ok thanks for the pointer, I'll give it a whirl.

Had a go at simplifying things and have the following now...

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdee:e2bd:86fe::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6'

config interface 'wan'
	option proto 'pppoe'
	option ifname 'eth1'
	option username 'zen363864@zen'
	option password 'qKUGsLGB'
	option ipv6 'auto'
	option mtu '1500'
	option keepalive '0'
	option _orig_ifname 'eth1'
	option _orig_bridge 'false'
	option peerdns '1'

...and data is passing through both WAN and WAN6 when I view the config on Luci.

However my phones, tablets and Raspberry Pi's still don't connect to the internet so I think this may be a DNS issue, which is why I've tried adding peerdns to the WAN config.

My /etc/config/dhcp has the following...

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '1'
	option nonwildcard '0'
	option port '53535'
	option serversfile '/tmp/adb_list.overall'
	list server '1.1.1.1'
	list server '1.0.0.1'
	list server '51.254.25.115'
	list server '188.165.200.156'

config dhcp 'lan'
	option interface 'lan'
	option start '2'
	option limit '20'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	list dhcp_option 'option:dns-server,192.168.1.1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'

...which has worked in the past so I'm unsure as to the next steps to trouble shoot this.

EDIT :

syslog shows nameservers being defined as follows....

Fri Apr 19 18:14:15 2019 daemon.info dnsmasq[5345]: using nameserver 188.165.200.156#53
Fri Apr 19 18:14:15 2019 daemon.info dnsmasq[5345]: using nameserver 51.254.25.115#53
Fri Apr 19 18:14:15 2019 daemon.info dnsmasq[5345]: using nameserver 1.0.0.1#53
Fri Apr 19 18:14:15 2019 daemon.info dnsmasq[5345]: using nameserver 1.1.1.1#53
Fri Apr 19 18:14:15 2019 daemon.info dnsmasq[5345]: using nameserver 212.23.3.100#53
Fri Apr 19 18:14:15 2019 daemon.info dnsmasq[5345]: using nameserver 212.23.6.100#53
Fri Apr 19 18:14:15 2019 daemon.info dnsmasq[5345]: using 10 more local addresses
uci -q delete dhcp.@dnsmasq[0].port
uci -q delete dhcp.@dnsmasq[0].server
uci commit dhcp
/etc/init.d/dnsmasq restart

https://openwrt.org/docs/guide-user/base-system/dhcp_configuration#upstream_dns_provider

Can you ping to sites on the Internet by number such as ping 1.1.1.1?

It usually works best to use either provider DNS or locally configured public ones, not both.

The "orig" option settings are an artifact of making changes with LuCI and you can simply remove them.

@slackline

worth deleting this post since you've posted your zen creds . Delete rather than edit since editing preserves the original post in the edit history (I think).

Thanks @vgaetera and @mk24

Yes I can SSH into my VPS from my Pi's as they have the IP address configured under ~/.ssh/config

@vgaetera suggestion will delete the port and current DNS servers I have defined, although I'd rather use those than the ones provided by my ISP, so I've removed them from the @dnsmasq[0] config as advised and also added them to the WAN...

uci -q delete dhcp.@dnsmasq[0].port
uci -q delete dhcp.@dnsmasq[0].server
uci commit dhcp
uci set network.wan.peerdns='0'
uci set network.wan.dns='1.1.1.1 1.0.0.1 188.165.200.156'
uci commit network
service network restart

And everything is working again \o/

No idea how network.wan.peerdns='1' got set as I'd previously configured thought configuring dnsmasq to handle things, but now I've that in place under network.wansettings all is good.

Next challenge will be to get one of DNSCrypt or DNS over HTTPS working.

Thank you both for your time, advice and assistance, very much appreciated.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.