[SOLVED] Archer C7 v5 Image buider

I'm buiding a custom firmware to Archer C7 v5.

I'm trying to build it from from stable openwrt-imagebuilder-18.06.1-ar71xx-generic.Linux-x86_64 but I can't flash it to the hardware although I can flash the "off-the-shelf" version:


I thought it was something with my customization but after double checking it and rebuilding I still can't flash via console nor tftp. If I force using sysupgrade -F I get the hardware sort of bricked and then I have to reinstall the OEM firmware via TFTP.

I found out that there is also a snapshot for this hardware:


From another topic I found out:

ar71xx is deprecated and will shortly be discontinued. ath79 is the current target for those SoCs.

ath79, at least last I read, would not be built for v19, even though ar71xx has been "strongly discouraged" (to the point of refusing new devices and patches for months now).

This leaves users only snapshot builds off master for ath79, which is the only viable target for the device.

I'm a bit confused is it still possible to buid from the stable ar71xx ImageBuilder?

ar71xx is supported for v18.06

Both ar71xx and ath79 are available for v19.07, presently in "pre-RC" status, with no firm release date.

Future development work should be targeted to the ath79 target, as ar71xx will be "source only"

So I'm assuming I'm doing nothing wrong building from:


And flashing to Archer C7 V5 (US).

Am I right?

I don't use the image builder as I build from source, but given that the Archer C7v5 appears to be supported on the ar71xx target for 18.06.4


that appears to be a correct image builder to use.

It's been a while since I've used IB for ar71xx, but most likely you're either including something in your image which is breaking the router or you're flashing the wrong file.

I use imagebuilder for c7v5 with no problems, however I use it from trunk and ath79. Unless the older versions only support ar71xxx and not ath79 I can't see the point in using a soon to be unsupported variant (ar71). ymmv


Greybeard, what you mean by trunk is https://downloads.openwrt.org/snapshots/targets/ ?

There is no ath79 in version 18.

Yep, snapshots.

“trunk” is a term that means the main branch of development. For OpenWrt, it is the master git branch, which is the source of the snapshot builds.

Personally, I agree that 18.06 and 19.07 are too old to be using if you’re building your own images or packages.

Hi Jeff, thanks again for your answer. I'm going to install the firmware in more than 1000 devices. Considering that, for me it would be important to have a stable version with a history of known problems, but I'll take your advice into consideration. It's also known that the kernel that comes in version 18 has some performance limitations that impacts this hardware.

At least in my opinion, especially as you're building your own firmware, pretty much any point on master is as stable as any other. Pick a commit, tag/branch it in your local git, and build from source from there. If you also tag the package feeds, you can have your own "point in time" locked down for your fleet.

jeff@deb-devel:~/devel/openwrt$ find . -type d -name .git
1 Like

I also tried building a standard firmware without customization to check if that was the case:

make image PROFILE=tl-wr1043n-v5 

Should generate a "pure" image without changes that could cause a problem.

I still get the same error from luci (tried in versions 18.06.2 and 18.06.4):

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

And from sysupgrade:

Image check 'fwtool_check_image' failed.

From OEM I just get:

Incorrect file type

Only if you do make clean before it.

I do make clean.

It looks like I was using the wrong profile all the time. Archer C7 v5 has its own tp-archer-c7-v5 profile and I was using tl-wr1043n-v5. Should have paid more attention :face_with_monocle:. Thanks everyone.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.