(Solved) Archer C7 V2 Failsafe

Had Lede running on the router and decided to use it as an extender/bridge and could only get one of the two radios to work at a time so while tooling with different configurations. The last time I had communication was setting it to a "client bridge". The ip was 192.168.3.1 and the dhcp server was OFF.
I have researched this in the forum and I don't see any tp-link Archer C7's successfully entering failsafe mode I was curious if there was anyone who had done it or if there was and alternative method. I can see both wireless radios and even connect to them but that's as far as it gets..

I have followed the documentation on trying to get the unit into Failsafe but no luck. When booting I can clearly see the blinking power led patterns and have tried to push a button but nothing. I have watched with a packet sniffer and at no time id there ever a packet that contains the text “Please press button now to enter failsafe”.

What am I missing? I don't think it's a brick but it is certainly unreachable.

If you can SSH into the router at 192.168.3.1, run the following commands...

firstboot

reboot

Otherwise, use this tutorial on the TP-Link forums to revert to stock firmware, and flash LEDE again...

http://forum.tp-link.com/showthread.php?81462-How-to-recovery-the-router-when-you-bricked-it1

Rename the stock firmware file archerC7v2_tp_recovery.bin

jwoods

Thanks for your help but it seems that every recovery method for this router depends on the reset button which, unless someone knows better, is purely decorative after flashing Lede. I was able to capture the right port with a packet sniffer and did see the message about "pushing a button" but again, decorative only.

Thanks again but at this point I am ready for the router to have an "electrical accident" and return it to the manufacturer (2 year warranty). Don't think I can return it right now with the radios broadcasting "Lede".

Any other suggestions. I appreciate them all!

tftp on C7V2 works for me, just did it a few weeks back.

Edit:
Sequence something like:

-hold reset button as power on
-all leds on (including WPS)
-leds off
-some leds on (no WPS)
-leds off
-few leds on but with WPS
-release reset button ~1-2 secs.
-switch led in use should indicate traffic(assuming your tftp server is ready)

Pressing the reset before turning the power on and holding it will always put the bootloader in TFTP recovery. LEDE never loads.

As mentioned above, when using the steps in the provided tutorial, the reset button works fine.

I have recovered C7 V2's many times using this process.

Works for other TP-Link models as well.

Common issues I see...

  1. TFTP server running on the attached computer does not have permissions through the firewall.

  2. Router not powered off first.

  3. Reset button not held in for at least 10 seconds after the router is powered on.

Okay, maybe I'm missing something so I will regurgitate my exact process.

Ethernet on laptop set to 192.168.0.66
Settings:
TFTP
Global
Only TFTP server is checked
TFTP

  • Configuration - Port 24
  • Security ? None/Standard - didn't matter

Advanced

  • Option renegotiation
  • Show progress bar
  • Translate Unix
  • Bind TFTP Server 192.168.0.66
    Firewall permissions set in/out
    With the router off and reset button held power button is pressed - reset is held throughout the entire boot process.
    Nothing?

Question - If the reset button is pressed and Lede is not supposed to load, why can I see the radio channels available?

I definitely appreciate the assistance!

iirc, if a tftp server is not detected within a timeout period the boot process continues. TftpPort=69?

Nothing should be changed in Settings. The defaults are fine.

Port should be 69

Security should be Standard

Bind TFTP Server should be unchecked

The router should be off. The TFTP Server interface should be selected to 192.168.0.66

The reset button should be pushed in at the same time the router power switch is turned on. Release the button after 10 seconds.

What firmware file did you rename to archerC7v2_tp_recovery.bin?

To all that responded... Thanks!

The link in the original post talked about port 24 not 69 and also gave directions on "binding" the ip. After reading the last 2 posts I fixed it in 30 seconds.

Thank you again!

Glad you got it fixed.