[Solved] Ar71xx Kernel 4.9 PPTP Passthrough not working (TL-WR942N v1)

Hi !
I am replacing the TP-Link TL-MR3420 v2 router
Firmware VersionOpenWrt Chaos Calmer 15.05 / LuCI (git-15.248.30277-3836b45)
on
TP-LINK TL-WR942N v1 (OpenWrt SNAPSHOT r5985-33e8f7ee49 / LuCI Master (git-18.030.59690-47d1eaa)

The PPTP client does not work on the new device. Client settings on both devices are identical.

In addition, through a new router with this firmware, the PPTP connection from Windows 10 to the remote PPTP server does not pass.

kmod-nf-nathelper-extra is already installed.

What could be the problem ?

Good news:

from BUG tracking --Arjen de Korte прокомментировал 02.12.2017 21:22***

_This is not surprising. The default for automatic loading of connection tracking helpers was changed _in kernel-4.7. So with kernel-4.4, the pptp helper will be loaded automatically when PPTP traffic is _seen, but for kernel-4.9 you'll have to do that explicitly. _
Adding something along the lines _
_ iptables -t raw -A OUTPUT -p tcp -m tcp --dport 1723 -j CT --helper pptp

should load the connection tracker helper in your firewall. You could append this line to your /etc/firewall.user for instance to load it automatically.

Ok.
Next bug:


root@OpenWrt:~# iptables -t raw -A OUTPUT -p tcp -m tcp --dport 1723 -j CT --helper pptp
iptables v1.6.1: can't initialize iptables table `raw': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.


What should I do ?

PS. Thank you in advance

Where did this information come from???

Please install the full version: 17.01.4. Snapshots are similar to "Release Candidates." They may also be missing software (e.g. snapshots usually do not contain the LuCI web GUI). PPtP may not be setup in the snapshot you flashed.

You have to install RAW tables support (kmod-ipt-raw)...but I'm not sure that will help.

Please install the full version: 17.01.4.

Not possible for WR942Nv1

Where did this information come from???

https://bugs.lede-project.org/index.php?do=details&task_id=1083

You have to install RAW tables support (kmod-ipt-raw)…but I’m not sure that will help.

It helped, but the PPTP does not work.

1 Like

See also [Solved] Help=> can't initialize iptables table `raw'

See also Help=> can't initialize iptables table `raw'

Yes. This is my post.

@tmomas means that you have posted the same issue in two different threads...

@jwoods No, these are two different problems.
In the second, it means that there are errors in the dependencies of package dependencies. In the description package iptavles directly indicates support for RAW, however, without the additional module loading it does not work. Whoever searches for a description of the problem will find it easier to see the answer and get a solution

Same thing with this problem.
If you carefully read my posts above, the problem is known since October 2017. Nevertheless, there is still no solution.

Ar71xx Kernel 4.9 PPTP Passthrough not working.

Working, working. Add net.netfilter.nf_conntrack_helper = 1 in /etc/sysctl.d/99-pptp.conf (create this file) and reboot router.

This was included in your second post in this thread...

Then you started this thread with the exact same issue....

I don't see where it's a "different problem".

1 Like

Incorrect. There are many modules in LEDE that have to be installed first. There is no bug, you simply install the correct module. There are also other types of uncommon tables as well (e.g. tarpits), is that a bug that they're not installed too?

@cezary noted this. Have you tried it?

These all seem to be threads and bugs involving YOU...what makes you think it's a helper...and perhaps not something like unblocking GRE?

Yes, it works for me (openwrt snapshot, kernel 4.9, ar71xx / mikrotik)

Asking the OP to test.

YES! Working.

But /etc/sysctl.d/99-pptp not exist.
I added this line to the file /etc/sysctl.d/local.conf,
But it does not matter. :slight_smile:

A little later I will make a clean installation and write the result.

Hi !

I made a completely clean installation with
OpenWrt SNAPSHOT r5986-3f7908d / LuCI Master (git-18.031.70145-518ac52)

  1. Install the packages

opkg update
opkg install kmod-nf-nathelper-extra

  1. Add a line to the file /etc/sysctl.d/local.conf
    net.netfilter.nf_conntrack_helper = 1
    and reboot router

PPTP Passthrough works !

Many thanks to @cezary for the short and clean answer.

4 Likes