[SOLVED] 2x OpenWrt devices: one router and one client

Hi,

I have two devices which both run the latest stable release 18.06.5. Unfortunately, my Netgear EX6150v2 rage extender cant connect to internet. It is not about configuring as relaydaemon yet, I first want to make it connect to the internet in order to update LuCI with latest updates and download the necessary software.

I can connect to both of them with LuCI and SSH. I gave the first device (TP-Link router) 192.168.1.1 and the Netgear device the address 192.168.1.2 and told it to use 192.168.1.1 as gateway and checked Disable DHCP for this interface in Network > Interfaces > LAN > Edit. Although these steps are not unfamiliar to me, I checked the quick start troubleshooting guide

Network diagnostics shows me:

Ping: "ping: "bad address 'google.com'" but if I go for 8.8.8.8 or 192.168.1.1 everything is fine!
traceroute: "traceroute: bad address 'google.com'" plus same as above
NSlookup: ";; connection timed out; no servers could be reached" - doesnt matter if I search for 8.8.8.8 or google

Similar behaviour when I SSL into the box:

root@OpenWrt:~# opkg update

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.5/packages/arm_cortex-a7_neon-vfpv4/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

Any ideas what I could check next?

Thx for any input!

inc0gnit0

have a look on /etc/resolv.conf

1 Like

Whatever you do, do not use opkg upgrade on any openwrt device unless a) you know what you are doing and upgrade only specific/known safe packages, or b) are willing to deal with the fact that you will almost certainly have problems that will require a reset to defaults situation.

I say this because you do not need to, and should never upgrade any of the core openwrt packages with this method (and you mentioned doing just this in your op). It will break things. Period.

Using opkg update followed by opkg install is, of course, totally fine to install additional packages.

1 Like

You need to also tell it to use 192.168.1.1 as the DNS server...

Basic "dumb AP" advice in wiki:
https://openwrt.org/docs/guide-user/network/wifi/dumbap

My old post about it:

2 Likes
root@bridge:~# cat /etc/resolv.conf 
search lan
nameserver 127.0.0.1

Gateway and DNS address have been both set earlier, but that didnt do the trick. :-/ Thx for all your help!

Can you look at the actual setting from /etc/config/network under LAN. If there is no DNS, add it:

option dns '192.168.1.1'

I'm not sure why @siga asked you to show /etc/resolv.conf

1 Like

hnyman! Your link did it! I also had to disable firewall, dnsmasq and odhcpd! Thank you ALL so much for being so helpful! :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.