[Solved] 19.07 Upgrade renders Wireguard Client Inoperable

This post is intended to provide feedback re 19.07

Box=Archer C7 v4.

I upgraded from 18.06.5 (target= aR71xx) to 19.07 (target; ath79)
Result is Wireguard Client unable to connect to VPN server.

After many hours playing with different settings I reverted to 18.06.6 ar71xx - which works fine.

I have WireGuard running on 19.07 just fine. If you share the errors you're seeing people might be able to help/investigate.

1 Like

Update
I successfully connected wireguard with 19.07 using ar71xx as the target instead of previously used ath79 target.
Conclusion: bug in ath79 target????

More likely some configuration issue exposed by ath79

1 Like

WireGuard working perfectly on my 19.07.0 installation after a move from ar71xx > ath79 target (Ubiquiti RouterStation Pro).

After you switched to ath79, how did you 'restore' your configuration for Wireguard?

1 Like

I tried a couple of ways installing 19.07 with the ath79 target:
1/ Clean install + manual configuration of wireguard.
2/ Restored from a backup taken from 18.06.05
However, neither method worked for me.
As i said earlier, I managed to get 19.07 ar71xx working no problem.

Do you still have your config files from the ath79 based tests? Specifically
/etc/config/network
/etc/config/firewall

and your config file from one or more of the remote peers.

Obviously be sure to redact the keys and public IP addresses, but please don't obscure the other details and make it clear what you are redacting so that it is clear that it is not a mistake.

2 Likes

I successfully connected Wireguard with 19.07 using ar71xx as the target instead of previously used ath79 target on Archer C60 V2

No, I'm afraid I don't have any config files.
When I get some time, I'll have another go at ath79 - this time I'll generate and save the config files you mention.
Thanks for your help todate

Solved
I flashed from 19.07.0 ar71xx to 19.07.0 ath79 and wireguard worked seemlessly.
I can only assume that flashing from 18.06.05 caused the problem?

This seems highly improbable to me, assuming that 'keep settings' was not used (unchecked via LuCI or '-n' argument on the CLI). When the flash operation is performed, nothing is retained. So it makes no difference if you are upgrading from a previous version or cross-grading between targets (or both simultaneously). IMO, what is more likely is that it was a configuration error (either retained due to accidentally having 'keep settings' enabled or something added/omitted or some other typo during the re-configuration process).

FWIW, I upgraded my RouterStation Pro from 18.06.5 (ar71xx) to 19.07.0 (ath79) directly, reinstalled packages, and then transferred my configuration manually (selectively) back into the RSPro. Everything worked perfectly when I had completed the process.

I was very careful and selective about what files I copied directly as well as those that I copy/pasted sections, and I did not move any files that were not directly relevant to my configuration. All files that planned to touch were carefully reviewed to ensure compatibility. I found that it was safe to simply copy (scp) many of the non-hardware specific files (i.e. firewall, dhcp, openvpn main config file, etc), but the /etc/config/network file required manually editing the configuration (including my network IP declaration and copying the OpenVPN and WG related interfaces over, but using care to not edit/replace the majority of the file with the previous configuration details). It would be easy to introduce a typo or some other minor configuration error by mistake, or to omit the installation of a specific package. But, if approached with attention to detail, there is no reason to suggest that the upgrade+crossgrade was the source of any issues.

1 Like