[SOLVED] 17 -> 18: IPv6 working, but not IPv4, no IPv4 DHCP leases on all devices

First, thank you for visiting this thread. I will try to describe my situation as best as possible, and then describe what I have tried to amend the situation.

Here are the devices connected to my OpenWRT router:

  • Nokia 6.1: latest Android, using Cloudflare IPv4 DNS servers -- works
    This device works, both IPv4 and IPv6. Interestingly enough, I did not need to set anything for it to work. I am able to use this device to connect to LuCI. Local IPv4 is 192.168.1.115, set as static (this was the address when I was using OpenWRT/LEDE 17).

  • Windows 8.1: tried both auto DNS detection and Cloudflare IPv4 + IPv6 DNS
    Because IPv6 is working, I can connect to google.com, but not duck.com, for example

  • Windows 10: same as Windows 8.1

  • Raspberry Pi 2B: I cannot connect via public IP address, but I can via local IP address (192...)

  • Archer C7: I do not have port 22 open

The problem I'm seeing is that on my LuCI, I don't see any DHCP leases for IPv4, but there are leases for IPv6. I have no idea why it would not have any DHCP leases for IPv4 for all my devices, but it has all the IPv6 leases for them. Yet, my Android works with IPv4. How do I approach this problem? Where do I even begin to tackle this problem? What is happening?

What I have tried so far:

  • On both Windows devices, I tried to set the DNS to auto-detect and Cloudflare for both IPv6 and IPv4. Google works (as well as this forum), but not DuckDuckGo.

  • ipconfig /renew and /release (ipconfig doesn't show anything that's IPv4 except Autoconfiguration IPv4 Address and Subnet Mask)

uci show network; uci show dhcp
ip a; ip -4 r; ip -4 ru; ip -6 r; ip -6 ru
ls -l /etc/resolv.* /tmp/resolv.*
head -n -0 /etc/resolv.* /tmp/resolv.*

https://openwrt.org/docs/guide-quick-start/sshadministration

Is there a command line on LuCI web interface? I cannot connect to the router through SSH.

Edit: I just found out that I can set the SSH through LuCI and open port 22! I will try these commands. Thanks.

Edit2: Interestingly enough, I found something I didn't expect after running the first command.
network.wan.dns='198.206.14.241 198.199.84.126 162.248.241.94'
I never set these DNS servers. Are these OpenNIC + Backplane DNS servers default for OpenWRT?
Moving on to the next command...

Screenshot%20from%202019-04-18%2010-47-47

And from my location, they do not reply to DNS inquires.

1 Like

Solved!

It seems that with the upgrade, the new resolv.conf file did not have any DNS server registered. Thanks!

Edit: not solved :frowning:

My Windows devices still aren't getting IPv4 addresses and can't use access IPv4 website.

1 Like

It is generated and populated based on network and dhcp configurations.

1 Like

It seems that I cannot change the IPv6 DNS. It changes it by itself to

2001:558:feed::1
2001:558:feed::2

What in the world...

Edit: Still no active DHCP leases for IPv4, trying to snoop around more...

https://openwrt.org/docs/guide-user/base-system/dhcp_configuration#dns_provider

These are Comcast IPv6 DNS servers. You can set your own DNS servers here:

On WAN (yes, you can add IPv6 server here too):

Screenshot%20from%202019-04-18%2012-07-02

On LAN:

Screenshot%20from%202019-04-18%2012-07-34

2 Likes

No no, I already tried changing the IPv6 DNS to Cloudflare's IPv6 DNS. However, all of the resolv.* files change back to 2001:558:feed::1 automatically.

Uncheck "Use DNS servers advertised by peer" on WAN6 (and you can add them there, too).

1 Like

Oh thanks, didn't know there was separate setting for IPv6. I have unchecked it.

Interestingly enough, IPv6 still works with Cloudflare IPv6 DNS, but IPv4 does not. Still no IPv4 DHCP leases for all my devices.

Edit: On LuCI, these are all my WAN advanced settings:

Bring up on boot 1
Use builtin IPv6-management 1
Force link 0
Use broadcast flag 0
Use default gateway 1
DNS servers advertised by peer 0
Use custom DNS servers 1.1.1.1 1.0.0.1 (two entries)

and the rest are blank.

Edit 2: Is it alright that LAN is static protocol?

Edit 3: Visiting Google on Windows 10 works, but not on Windows 8.1...? I'm going to look in to the DNS settings for each. -- SOLVED edit 3

Edit 4: WAN2 has "unsupported protocol type"; and it gives me a link to "install protocol extensions..." which leads me to software installation with luci-proto filter, but I'm not sure which one I'm supposed to install. My current process of elimination is:

  • not luci-proto-3g (3G mobile network?)

  • not luci-proto-ipv6

  • not luci-protoopenconnect/vpnc/wireguard (I can't even connect via IPv4 anyway)

So which one do I install?

LAN has to be static protocol. If you change it, your LAN doesn't have a dedicated IP and you loose connectivity.

This is the first you've mentioned a WAN2. That was very important information. What have you setup a WAN2 for?

I have no idea. I don't remember it at all. I strongly doubt I set WAN2 with some purpose. I thought WAN + WAN2 were 2,4 GHz and 5 GHz wireless connections. I thought it came with OpenWRT. Should I just delete it?

I'd reset the router to defaults, to make sure you didn't accidentally add or re-configure anything else.

As long as you're referring to WAN2, and not WAN6 - feel free to remove it.

Ok, resetting worked. I'll mark this as solved. Thanks

I guess it's time to reinstall all the packages again!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.