SOLUTION reinstall stock firmware TP-LINK ARCHER C6 v2 (EU)

Hello everyone, first apologize for my bad English.
The solution for all those who want to reinstall the stock firmware of the tp-link archer c6 (EU) is simple, first we look for this firmware ArcherC6v2_eu-up-ver1-0-1-P1 [20180627-rel42764] .bin which is the Older and it is the one that comes from the factory, second because after downloading it as usual, take and load it in the router with the TFTP to reinstall it if everything goes well we will have the serial firmware installed again ...

Here you have the link:

I hope it helps all of you who want to reinstall it again, I went crazy until I found it.

I tried to revert but sill no luck :confused:
The router came with FW 1.3.6, I installed Openwrt 19.07.7. I tried to revert to stock via TFTP and with 1.3.6 even 1.0.1 stock FW the router always ends with just power LED ON. Only thing to get it work again is to flash OpenWRT via TFTP.

file's deleted from the 4shared site, but can be found here

1 Like

Yep, but even with 1.0.1 the revert doesn't work for me.


and you did actually write it, i just missed it in the text :frowning:

I don't suppose you have a serial cable you can hook up to the C6 ?

I have serial, I just didn't wanted to disassemble it immediately after buy :smiley:
If I will have more time, I will maybe try it with serial cable. I just wanted to test 5GHz again, because on OpenWRT it looks like the performance is lower then on stock (330/270 vs 380/460Mbit on half Duplex and 310/15 vs 190/260 Mbit in Full Duplex with iPerf3 20 connections).

I have exactly the same problem. My router come with fw 1.3.6. I tried to downgrade it using this solution (flash openwrt, then original fw 1.0.1), but without success. Openwrt boots fine, but original fw boots only in version 1.3.6. When I flash lower version, router stays stuck at boot (only power led stays on). If you find a solution for this, then let us know. I don't have the possibility to solder serial port ...

thanks for uploading it in a static link.

It gave me the same problem and the solution was to go to the network adapter and set it to 100 megabytes, not as I had it to 1giga, in this way it was installed via TFTP without problems

You will be doing something wrong without knowing it because I had to go back to stock several times and it was a failure of the speed of the network adapter that you have to set it to 100 megabytes

try to install it as I told someone here, go to the network adapter and instead of full leave it at 100 megabytes to vwer if it works that way because that was the problem for me

I went down this road, too, this night.

The short story: I had to use Stock FW 1.3.0 (see link at the end of this post)

The long story: :sweat_smile:
My Router was delivered running Stock FW Ver 1.3.6, too. I successfully flashed OpenWRT 21.02.0-rc3 through WebGUI. At this time I had already read about the hurdles going back to stock FW, so I had stock versions 1.0.1 and also 1.2.1 at hand for reverting back with TFTPd64. Both versions were successfully transferred by TFTP. But despite successful transfers of the files the router just seemed to stop working. After waiting for about 5 minutes I powercycled the router and it came up with OpenWRT again. I searched TP-Link website and the oldest FW I could find was Version 1.3.0 with a footnote, that this FW-version introduces new Features (i.e. OneMesh-functionality) and therefore it wouldn't be possible any more to downgrade to a Version earlier than this. So I gave FW ver 1.3.0 a try and that did the trick. After TFTP-transfer completed it took about 1 minute of time, then the router rebooted automatically (took long time for booting, again more than 1 minute, I guess...) and at the end it came up again running stock 1.3.0 Firmware. I could update do latest stock 1.3.6 the usual way through stock WebGUI. Hope, this might help somebody in their try.

Link to Stock (EU) - 1.3.0 (200402 - r52000)

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.