Software for Pi Zero 2 W

Im not a developer but this seemed liked the best category to put it under.

I received my Pi zero 2 W and was going to install OpenWrt and noticed this was an issue [Raspberry Pi Zero 2 W]. So i was wondering what the progress of it was, if there is a solution or not yet? I have OpenWrt installed on 2 archer c7's and it has worked flawlessly so i was looking into a more compact form factor to load this great networking firmware onto!

Check the table of hardware, if the device is listed then the issues were overcome and support added to master.

vendor has been asked to provide a licence and submit to linux-firmware

suggest you let them know not having this makes your purchase crippled, and documentation stating these fact would be good to know prior to making a purchase

2 Likes

Hi all,
I have an OpenWRT project for which the Zero 2 would be perfect but I understand there to be licensing issues with the firmware.
Are there any updates on this? If the problem is just the WiFi firmware…can we build a working version without WiFi (use USB etc)?

Hey, you’re certainly free to build your own image without wifi.
The device won’t get merged without it though.

There are 5 patches in the patch-logs that never merged.

In have them on the desktop if you cant find them (patches by @stintel not me). I tried to build master with them but I got some problems building the image.

Ill try again…

I've contacted SFC on 20/12/2021 regarding the matter. I have not received a response so far.

If there a way for individuals to build your 5 patches on top of the current or 21.XX git code?
Thanks

The patches were developed (and only tested) against master.

Maybe it was me then. It didnt compile. Ill check it again.
Was there a particular commit I better use please?

Thanks

Are there any updates regarding this topic? Seems like the GitHub issue got clarified.

Any answer is appreciated!

1 Like

Firmware would be also useful without Wifi support. Mediatek USB Wifi can be used.

1 Like

indeed I have a working version but in reality I ended up not using the build-in wifi and adding two USB cards

is there any possibility to find the version that works too?