Softbricked Mercusys MR70X v1

The "factory" firmware was upgraded via Mercusys original fw and the LuCI worked fine. During the configuration I messed with a lot of settings to make it work as a repeater for a non-openWRT AP and looks like the factory reset did not cleared everything(e.g.the 3rd wireless option was absent). Then, I decided to reflash, but I selected the factory instead of sysupgrade... I waited for more than 10 minutes and decided to turn it off. Then, as expected, does not work.
But, oddly, if I manually change the computer IP for 192.168.1.x and try it, there is the Mercusys boot error page asking to upload/upgrade the fw file, the process goes until 100% but it fails with Mercusys or openWRT.
I also tried ssh but port 22 refuses the connection.
I configured a TFTP server using tftp64 but it does not show any logs using the 3 ports or even WAN (I tried even as some people using tp-link on some forums mentioned worked for them) while pressing the reset button for some seconds before turning off and keeping it pressed, actually the reset button looks like does not work.

Any suggestions aside of hardware-related ones?

Thank you!

You will need a serial connection to see why the device is failing to boot