Soft bricked AVM FRITZ!Repeater 1200

I have recently bought the AVM FRITZ!Repeater 1200 and successfully installed the stable 21.02 according to the device page instructions (
However I had issues with the performance when using mesh.
Therefore I wanted to check out if WDS might be better with my setup as of now.
WDS is broken with the stable 21.02 (WDS Configuration on 21.02 - #27 by chadneufeld) and I therefore decided to flash 21.02 rc3 and keep the data.
Afterwards the devide was responding very slowly (via webportal and sssh) and I decided to perform a soft reset.
Since then I can't access the device via ssh nor web gui and when pinging I can see that some packages are dropped, while the higher percentage pings back.
I believe I might have run into this bug:

I have tried the following things: in failsafe it does not respons at all to pings to (could it have a different ip?)
I can get it to boot the u-boot (first step of the instruction), but it then doesn't wait for the new image in tftp, but instead boots the broken image again.

I have additionally tried the AVM recovery tool, but that failed to detect the device every time.

How and when in the boot process can I get it to load another image from tftp in order to unbrick the device?
Thanks in advance

I tried again with the recover tool from AVM and this time also had real time protection from Windows Defender off. I also confirmed a pop up asking if I would like activate LAN discovery on that network.
Eventually the recovery was successful and I can now properly access the AVM firmware.
However I am now struggling to reinstall OpenWrt. I can never ping during boot ( responds to the ping eventually as expected). Therefore I am not able to boot the u-boot as stated in the instruction.
Could this be due to a very new AVM firmware (7.27)? I am not sure which one was installed at the beginning.

I found out, that the repeater is available under for some seconds during the boot process instead of
I therefore used the on that ip instead and then could get it boot the initramfs image from tftp and I followed the instruction and now I am back with OpenWrt 21.02 on my repeater :smiley:

So this means the AVM recovery did not restore the bootloader, but still keeps the uboot-fritz1200.bin.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.