So I got the XR500. Now what do I do?

I have an R7800. Now I also have an XR500 but we're not hitting it off.

tl;dr: I bought an XR500 but wanted to run some tests with the factory firmware - Duma OS - before flashing to OpenWRT. After setup I'm experiencing some long lags, timeouts, and disconnects externally and connection problems on some lan devices (but not all). I think that it is a gateway /DNS issue but can't find a way into the Duma OS to see. I was about to move on and flash OpenWRT but wondered if the behavior might be hardware. How to tell?

I decided to buy another router because: 1) I need to add a managed switch and ap to my network 2) A "hot-spare" seems like good practice 3) My new ISP and I are trying to figure out some performance issues. We're mostly pointing at each other but they question my router / OpenWrt. If I needed (wanted) a new router, I could do some testing with factory firmware before upgrading to OpenWrt

I decided to buy an XR500 because 1) My R7800 has been rock solid through several configurations 2) I couldn't find another R7800 that I thought was worth the money 3) I picked up from the discussion "XR500 vs R7800" that R7800 and XR500 were kissing cousins. 4) I also read in this forum that DumaOS was rumored to be quite good

I got the XR500 yesterday. From what I've seen in the one day that I've had it, the DumaOS has got a lot of gee-whiz but is short on function and stability. E.g. it seems like it has the gateway hardwired to the ISP address. But in my case they are not the same address and I can't find that there is any way to let the router know. E.g.2 DHCP seems to be dishing out the addresses but doesn't necessarily connect - lists the AV receiver as inactive even though it's cabled, it's on and trying to connect. E.g.3 the DumaOS forums and Reddit sub.

So now what? Is the problem with this router the Netgear firmware / OS or is it the hardware? Should I flash it with OpenWrt and hope that I have an R7800 with racing stripes or send it back? If I put OpenWrt on it and it turns out to be hardware, will I be able to get the factory firmware back on it so that I can return it?


Your decision.
In terms of performance and behaviour, the r7800 and xr500 will be identical.

Make sure that the hardware is fine before flashing OpenWrt, while you can still return it. You can return to the OEM firmware via tftp, but there have been potential fragilities reported for the xr500 in the past - so don't do this unless really necessary; make your decision about keeping- or returning it before.


ipq8065 (no NSS) is good for up to ~500 MBit/s WAN speed (maybe 600-650 MBit/s if you're lucky), around 180-190 MBit/s with SQM enabled; PPPoE usage will incur some further performance penalty.

right now the upcoming DSA migration will worsen that a bit in the future, hopefully that can be rectified with the pending MDIO improvements and multi CPU port support.


Thank you. I wish that I had that kind of speed to work with. It is PPPoE but I'm just trying to get closer to the 50 Mbps that the ISP claims from the 35-40 Mbps that I'm seeing.

I appreciate your insights on flashing back (and the impacts of DSA migration). It makes the decision a little more permanent.

Is there a way, though, to narrow down whether it's firmware or hardware? The service that I have is beamed from a tower and has a private ip address for backhaul. I'm guessing that is a problem for the Duma OS but can't find how to check it. So instead, I put the R7800/OWrt back in line and set the gateway to the incoming public IP to see what would happen. OWrt shows the the public address that I input on the setup page but still shows the correct, private ip address, as gateway on the status page. Conclusion? If there is one, I don't have the knowledge to see it.

Under good circumstances, the r7800/ xr500 will easily achieve ~350 MBit/s netto over 5 GHz wifi, 2.4 GHz is obviously more challenged (more interference, contention, lower bandwidth) - 25-30 MBit/s would be reasonable there. There wouldn't be much potential for speeding up 2.4 GHz, aside from going 802.11ax (but it's more than questionable if your wireless ISP has 802.11ax 2.4 GHz hardware in service).

I have no personal experience with DumaOS at all, I can only say that -running OpenWrt- both devices are effectively identical.

Which fragilities? My plan for the evening was to try to flash back the OEM firmware, in order to give another look to this DumaOS and to practice with TFTP. Would you recommend doing otherwise? :slight_smile:

By the way, the Netgear page explaining how to TFTP has been slightly improved w.r.t. what I've seen here (just minor details which could however reassure a newbie, like explicitly stating to use port 69, the default TFTP port)

This is the same impression I had, but I bought the XR500 in order to install OpenWrt, so I haven't spent a lot of time on it.

I don't know that it relates to "fragilities" but the 30-30-30 reset method absolutely did not work on my XR500/DumaOS device. The "erase" option from the Administration menu cleared/reset it. Makes me wonder about flashing and reflashing. You apparently didn't have any issues flashing to OpenWrt?

Ok, I'll try to recollect and summarise my one-hour experience with DumaOS and the install process. I didn't take notes and there are some details I am uncertain about.

  • I bought a used XR500 from a guy who didn't appear really knowledgeable, who readily repeated he had used it only once and never again since it was a gift but he didn't actually need it. I paid it slightly more than 25% its official price.
  • The appearance of the router made me think the guy was sincere, but you never know: whenever something wasn't as I would expect it, I was always in doubt the guy messed up with something.
  • I installed it cascaded to my old router, in order to test it without fear of interrupting my family's connection. I connected my PC using a cable, I configured the connected port to use DHCP and turned the router on.
  • I tried in vain to access its web interface using the address (as stated on the quick start manual)
  • I opened the properties' page of my network interface to discover the router's address and was positively surprised because the router automatically recognised its WAN address was 192.168.1.x and therefore automatically set its DHCP to assign addresses on the subnet 10.0.0.x (I am not sure that I reported the actual subnets).
  • I was able to access the web interface using the router's address.
  • There was something wrong with the web interface: I dont' remember exactly what it was but it definitely appeared unreliable (I blamed the previous owner for this but maybe it wasn't its fault, after all). This made me immediately look on Netgear's website for updates.
  • I was probably running version and installed the most recent:
  • I was forced to define a password and the secret questions in case Iost it.
  • The interface appearance was good-looking, probably too much good looking to actually convince me.
  • It automatically set my country's langauge (maybe it had already been set by the previous owner) but the translation was poor (this is something quite rare: one of the reasons for we speak a bad english in my country is that good translations are the norm). I immediately switched it to english.
  • I had a brief look but as far as I can remember the much-advertised features were there but in general there wasn't so much to configure, or at least I wasn't able to enable the "advanced interface" (assuming that there is one). I remember I somehow kept feeling a bit distrustful of it.
  • I installed OpenWrt using the master snapshot factory image without issues

It is my first experience with OpenWrt, everything is new to me and I could therefore mistake bugs for features but everything of what I've had a look at is working as I would expect it.

I hope it helps. Do you remember which version of the OEM firmware was installed on your router when you installed OpenWrt? (Have you installed it?)

EDIT: According to this guy "Despite the mundane version number, this firmware update is the router’s most significant to date" because it upgraded from DumaOS 2.0 to DumaOS 3.0. That might have helped my migration

1 Like

Thank you. Close enough! I will likely flash to OpenWrt as I think it is most likely that the issues I'm seeing are in the factory firmware:

I've reset Duma OS twice since the first install but have had different weirdnesses each time; eg disruptions; bandwidth (2Mbps throughput on ethernet but 30Mbps on wireless); dhcp (showing active devices as inactive and wireless devices connected to the (ap) lan port). I've also seen a number of posts by XR500 owners complaining about the firmware being broken from 2018 and waiting over 2 years for the promised Dumas OS 3.0.

I don't remember the version but did upgrade. May explain why the behavior was different.

I can see xr500 binaries in snaphot for some time , but looks like not in 21.02.02 release ?

No, and it won't be - new devices will have to wait for 22.xy.0.

fwiw, I have had it running as an ap from snapshot for 3(?) weeks. Works well - clean logs.

slh - I'm surprised that the XR500 isn't fully supported as, from what I've read, it's an R7800 with more memory / storage. Not enough of them?

its a timing thing

yet the submission process took around two years with several submitters and hiccups along the way... (was not a clear cut case of lets clone the recipe a tweak a variable or two)

Just curious, I heard good things about XR500 with DumaOS 3.0 but don't know anything about it, is it Linux / OpenWrt based not sure. Does it support SQM? Adblock? Samba? Can't help but wonder if it's worth sticking with that for a while to thoroughly test it out and wait for Master snapshots for your target along with nftables etc. become more mature. Unfortunately we'll probably never see its successor the XR1000 get OpenWrt support because Broadcom.

Thank you for the background. Is there a category (forum?) that discusses candidates and status?

I struggled with DumaOS 3.0. To be fair, I didn't spend a lot of time with it but when researching the setup problems I was having I found several unhappy users. DHCP issues that were supposed to have been solved with Dumas 3.0 but Dumas 3.0 didn't come out for 2 years and it is actually version 2.3. That kind of thing. It has a lot of gee-whiz looking graphical features like drag-and-drop QOS (that a couple of reviewers said didn't actually change anything) but otherwise it seemed pretty locked down and limited. I did not find where to enable ssh before I gave up and flashed OpenWRT. In the 3 weeks since I put it in service the XR500 has been running well on OpenWRT as a dual AP.

1 Like

Just picked up an XR500 at a great price to replace my aging Asus RT-68U on ddwrt.

I was looking into openwrt for it and came across this thread. I've had ddwrt on my old Asus for years and I'm not afraid of the command line and have lots of linux experience, so I could install a snapshot. But as a first-time openwrt user, do you think I should wait for 22.xx..x? Is there a roadmap or tentative release date somewhere?

Hello Hawkeye, welcome!

As far as I understand, the next release will be released when it's released. You could try to guess it based on the previous releases.

If you feel like trying the new DumaOS, this could be the right time to do that, since some issues have been reported on the switch back. On the other hand the install process is quite easy and went smoothly in the last two reported installs (mine and @dwafun 's). Just remember that the Web interface is not included in snapshots. You'll have to install it manually.

1 Like

Maybe 4-6 months before OpenWrt 22 (don't know just a guess since it hasn't branched yet), this shoud have XR500 support. If you want to run OpenWrt now just install a master snapshot. They sometimes have issues, my WRT32X curently has ~100 day uptime and it's been flawless, but my build is right before the big nftables switch. Anyway here is the link to the daily builds try it use the 'factory' link. Master snapshots tend to improve continously so you can always update it maybe every couple of weeks until the next release:

Since it's just a snapshot it doesn't come with LuCI (the web inteface), so just SSH in and enter "opkg update && opkg install luci". Then you can connect to the web UI and configure everything, add other packages. I use: Irqbalance, SQM, Adblock, samba4, usb3, wireguard, upnp, nano, advanced reboot, iperf3, etc.

1 Like

Thanks so much @haakonpi and @phinn.

I played around a bit with DumaOS. Nice gui, seemed like performance was good, but lacking features I'd want on my router (and already have on my ddwrt router).

It should be easy enough to install a snapshot and install luci myself via ssh.

I'm coming over from the ddwrt world, so are there any "must have" packages that you always install on every openwrt router you set up?

My current network setup on ddwrt is pretty simple. Two 2.4ghz (IoT and guest), one 5ghz (main), Wireguard, slightly tweaked dnsmasq settings for pihole, simple mac blocking (don't want those ip cams phoning home to China!) and some basic qos on the guest network.

Read my post, in the last paragraph I said the packages you should consider adding after luci.

1 Like