Snapshot image builder cannot reproduce the "off-the-shelf" image

Hi, I am building an image for my zbt we 3526 router (rampis/mt7621). I can bring up the router with the "off-the-shelf" snapshot image directly downloaded from the resource page for the router.

However, if I try to build the image with make image command or make image PROFILE="zbtlink_zbt-we3526, the building processes show no errors but the images created cannot bring up the router. The images even have different sizes, there must be some inconsistencies in the process.

Does anyone know how to build the exact off-the-shelf image from the image builder? Thanks a lot!

BTW, rampis/mt7621 was supported by release versions of openwrt in 2018, but even the latest release version off-the-shelf image cannot bring up the router, only the snapshot can.

Snapshot Imagebuilder seems to be broken at the moment.
I am finding the exact same problem for ath79, ipq40xx and ramips/mt76x8.

The hardware I have tried is gl-inet ar300m, b1300, ar750 and mt300n-v2, plus ubnt/nanostation-m2
I would guess it is broken for all targets - don't know.
@jeff are you using imagebuilder or sdk?

It looks like anything built with Imagebulder (at least for the targets I have tried and the one @hungryPizzaria has tried), all soft brick the target into a crash loop. I can see the leds flash every few seconds on the gl-inet devices. No wifi, no response on ethernet, pretty much dead.

I build directly from source, so replicating an "off-the-shelf" image isn't something that I do.

Edit: Trying

I don't either, but I do build many custom images (imagebuilder is much quicker). It seemed to go wrong after the updates of around the 16th October, the last working version I had was just prior to that date.
I stripped down my build to "off the shelf" levels purely as a test.
The 19.07 version has not changed for months, so will probably work....

19.07 booted successfully. Trying

Edit: No GL-AR750S on 18.06.4

@jeff I'm sure 18.06.04 will be fine also, that has not changed for a very long time.

It is the 750 rather than the 750s that I was building for, but yes.

I don't have one of those on hand, but the 19.07 image builder is dated October 22nd.

It was rebuilt then I'm sure, but not changed though... probably.
Could you try current snapshot? It would be good to have confirmation of the issue.
Thanks in advance :smiley: is the current snapshot of the image builder (Oct 22). (Oct 22) boots my GL-AR750S successfully.

All the current prebuilt snapshot images will boot ok (for the hardware I listed), but any image created with snapshot imagebuilder fails, regardless of what you put into it - or leave out for that matter.
My conclusion is the current snapshot imagebuilder is broken. eg:

These all produce broken images that soft brick.

@jeff @tmomas where do we report this as an issue?

1 Like

Works OK here on GL-AR750S

tar xvf openwrt-imagebuilder-ath79-generic.Linux-x86_64.tar.xz 
pushd openwrt-imagebuilder-ath79-generic.Linux-x86_64
make info | fgrep 750
make -j12 image PROFILE=glinet_gl-ar750s
scp bin/targets/ath79/generic/openwrt-ath79-generic-glinet_gl-ar750s-squashfs-sysupgrade.bin root@
screen /dev/ttyUSB0 115200    # sysupgrade /tmp/openwrt-ath79-generic-glinet_gl-ar750s-squashfs-sysupgrade.bin

(successfully boots)

Downloading takes a couple of hours here (Highlands of Scotland). Come on SpaceX, get launching those Skylink sats :smiley:

I have a couple of 750S models - I'll break one out.
There have been some updates and a rebuild since I downloaded yesterday so I need to download again... with luck it might be fixed.

Wow! The latest (Wed Oct 23 21:46:58 2019) is 20MB smaller than the previous version.. very odd indeed. Now I just need to wait for it to download and hope i get it before it updates again.

hmmm interesting, the images created by 19.07 snapshot image builder cannot boot my router, but if build from source code the image can boot with base file and many kmod out of sync...the kmods packages are asking for an older base file...

If you build from source, you need to build the packages yourself as well, rather than use the OpenWrt repository.

1 Like

The current version of imagebuilder does work as @jeff found.
I have a "makeimage" script that adds all the packages I want, removing some others to save space - all in the normal way. Around the 16th of October something changed and the list of packages I was using started to cause problems. This was generated initially using opkg list-installed, probably a couple of years ago and modified frequently. This is what was causing the problem. Back then I had to add ALL the packages required even for the basic image (I am going back to OpenWrt CC here!).
This has been fine until last week.... guess I was lucky :wink:
Now looking at Jeff's example

is enough to build the basic "off the shelf" image.
It worked before, and I was lazy - not broken so don't fix it - ah well :smiley:

So now all I need to specify is just the packages I want and any to leave out (with a minus in front).
Recreated my makeimage script and all seems good.
@hungryPizzaria , follow Jeff's example and I think it will be ok

1 Like

(I'm lucky to have an AMD Ryzen for my build machine. If you don't have that many cores, or want to do something else while building, drop the -j12 down to something appropriate.)

1 Like

I have an elderly AMD SomeThingOrOther and -j4 seems to work well :wink:

1 Like