Smartphone does not want to use Dnsmasq

there's a difference between hijack and block ...

This is not my Phone, this is my friend's phone

On my $150 Samsung it is Settings->Connections->More connection settings->Private DNS.

2 Likes

In this phone model, we did not find such settings unfortunately

Phone model and android version?

on a Google Pixel "Private DNS" is in the Network & Internet sub menu.

1 Like

You do not use the DNS from the provider.

You either disable private DNS on the phone then
You send the routers IP address to use as DNS for your phone.
The router uses DoH or DoT to get secure DNS.

Or you let the phone use its private DNS and then you have to disable the DNS hijacking rule to redirect DoT in the luci-app-https-dns-proxy

All participants in this forum point you to the possible solutions, what is it you do not understand?

Same for my Samsung S20

1 Like

we'll look, thanks, I'll write when we find it, whether it helped or not

Thank you ! the problem was that he had the nextdns application installed on his phone, in general we sorted it out

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

1 Like