SmartDNS config with DNS over HTTPS

Hello, I have installed smart dns and I am able to run the dns over tls but when unbalt to run DNS over HTTPS.
I have tried cloudfare, google and also adguard https over dns (both by inserting port 443 in gui and without a port) . I Entered seperately but even though I can see with nslookup and in Luci that smart DNS is running but it does not resolve the DNS qeries.
Screenshot 2022-06-23 094910

Am I inserting the dns over htttps address correctly?

Screenshot 2022-06-23 095047

is it https-dns-proxy you're trying to use ?

No - this package: https://openwrt.org/packages/pkgdata/smartdns

haven't used the specific package, but is it set to answer DNS requests on port 53 coming from the LAN ?

Does it listen correctly?
netstat -lnp | grep 53

Smartnds is very good to speed up DNS queries : https://pymumu.github.io/smartdns/
I read the wiki and also wahtched you tube (in chineese). I have been using for dns tls and find it very qucik.
It is supposed to work with tls, https, udp, tcp. It runs as a dns server instead of DNSmasq on port 53.
Not sure if thoose using it can advice , in case there is any other config to enable https over dns


please see: not sure if it listening correctly?

dnsmasq is listening to 53. Have you configured dnsmasq to ask upstream the smartdns? Use 127.0.0.1#6053

1 Like

I thought it replaces the DNSmasq function of DNS resolution. It has below options and I choose " redirect 53 to port 53"
Screenshot r

configuration about resoution with TLS, UDP is working very well but not with HTTPS. This is the main problem I need help with

have you restarted dnsmasq after making the change ?

I reeboted the router after changes.

I stopped the DNS function of DNSMasq as above

What could be the next step I could do....

Apply the redirect, I suppose, unless it's done by using dnsmasq, as @trendy pointed out.

By the looks of the menu, the first option should update the dnsmasq config to use smartdns as upstream. The second option should try to bind on port 53, but if dnsmasq is still running it will fail.

1 Like

I tried as suggested above by @ trendy. No sucess and dns resolution completely broke down

I have done a reset now but still no sucess with Https over DNS Resolutions by use of smart dns.
It is interesting as other protocols resolution is taking place

This is how it is presently. Perhaps ISP provider may not be allowing dns over https?

DoH traffic is hard to distinguish from regular HTTPS traffic, so I doubt it.

you can always try to query the DoH servers you've set up using curl

You are correct DoH is not blocked by ISP

I am possibly not able to configure the DoH settings correctly in smartdns

I did like in this video (https://www.youtube.com/watch?v=z_dgnA7g1UA) at 3:42.

There are no more settings there but mine isnt working :frowning:

Try this:

image

2 Likes