Slow PPPoE on MT7621


I have a MT7621-based router (Asus rt-ax53u ) and 1 Gbps PPoE Internet connection. OpenWrt version is 22.03.3.

Internet speed WITHOUT PPoE software flow offloading: ~200 Mbps for 1 thread, ~400 Mbps for 2 threads

As enabling software and hardware flow offloading in Luci doesn't enable software flow offloading for PPoE and br-lan, I do it manually:

nft flowtable inet fw4 ft-bridges { hook ingress priority filter; devices = { pppoe-wan, br-lan };}
nft insert rule inet fw4 forward meta l4proto { tcp, udp } flow add @ft-bridges

Internet speed WITH PPoE software flow offloading: ~400 Mbps for 1 thread, ~500 Mbps for 2 threads

However, it's still far from 1 Gbps.
When I try to enable hardware flow offloading for PPoE I get an error:

# nft flowtable inet fw4 ft-bridges { hook ingress priority filter\; devices = { pppoe-wan, br-lan }\; fla
gs offload \;}
Error: Could not process rule: Not supported

According to information from other users of routers with the same MT7621 SOC, PPoE speed can be 800-900 Mbps. What can I do to reach this speed? I'm connected to the router via 5 GHz WiFI AX using 2x80 Mhz. I also tried doing speedtest on the router itself.

Thank you.

nft list ruleset | head -n 12
table inet fw4 {
	flowtable ft {
		hook ingress priority filter
		devices = { lan1, lan2, lan3, wan }
		flags offload

	flowtable ft-bridges {
		hook ingress priority filter
		devices = { br-lan, pppoe-wan }

Is it possible that this is relevant to you?

I’m not an expert, but if you’re stuck at 500/500 then that could be the 1Gbps routing limit.

1 Like

Thank you for the link. It seems like my router has a different issue.

22.03 doesn't have 2Gbit NAT so Your're limited to 1Gbit total throughput (gross) . If your UL + DL > 1Gbit it will be limited. Also There was hardware accelerations issues under 22.03 .
Try to load snapshort firmware via OpenWrt Firmware Selector and take one more test .

1 Like

Thank you for your email reply.

I don’t need 2 Gbps. I will be happy with 1 Gbps via PPPoE because currently, I have not more than 500 Mbps download speed although ISP gives me 1 Gbps.

I think you have wrong idea how this works. 2 Gbits mean there are 2 physical 1Gbit network cards in router in recent trunk . One is dedicated for WAN only .
In OpenWrt 22.03 hardware share single physical network card for WAN and LAN operation thats why you're limited to 500Mbit even in HWNAT. In 2Gbit (2x 1Gbit) configuration routing speed should go to 900-950 in HWNAT.

1 Like

Thank you so much for explaining. That makes sense. What if I configure the PPoE connection on LAN1 and plug the ISP cable there? Would it be a workaround? Actually, I tried it, but couldn’t connect to PPPoE. But I can continue trying if this can help.

I tried to build a custom image via OpenWrt Firmware Selector to include luci. However, the build fails even without changing pre-set package list. The error says "Unsupported package(s): nftables" after clicking on "Request build". I'm ok with installing the already-built snapshot presented on that webpage. But I'm afraid of installing a broken build that will fail to launch. Does the error above mean the snapshot build can be broken?

yes firmware selector seems to be broken at the moment but still You can get naked openwrt-ramips-mt7621-asus_rt-ax53u-squashfs-sysupgrade.bin and do opkg update;opkg install luci .

1 Like