Slow Internet/Disconnections on PPPoE

I started to have a problem lately on my connection.
I am on a VDSL2 Connection with a 30Mbps plan. The problem is I am getting PPPOE disconnections and inability to reconnect.

I am using Huawei HG630v2 as modem in Bridge Mode and WRT1900ACS for PPPoE connection and all other applications.

In case of disconnections and inability to reconnect,
The PPP log stops here

Fri May 22 19:38:19 2020 daemon.debug pppd[2273]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Fri May 22 19:38:19 2020 daemon.debug pppd[2273]: dst ff:ff:ff:ff:ff:ff src 14:91:82:2a:64:cf
Fri May 22 19:38:19 2020 daemon.debug pppd[2273]: [service-name]
Fri May 22 19:38:20 2020 daemon.debug pppd[2273]: Recv PPPOE Discovery V1T1 PADO session 0x0 length 44
Fri May 22 19:38:20 2020 daemon.debug pppd[2273]: dst 14:91:82:2a:64:cf src 84:26:2b:de:d4:cc
Fri May 22 19:38:20 2020 daemon.debug pppd[2273]: [service-name] [AC-name ALMAZA-R31A-C-EG] [AC-cookie d3 07 58 7c 1c e5 63 ba 43 f2 4a 64 2f ee 5d 28]
Fri May 22 19:38:20 2020 daemon.debug pppd[2273]: Send PPPOE Discovery V1T1 PADR session 0x0 length 24
Fri May 22 19:38:20 2020 daemon.debug pppd[2273]: dst 84:26:2b:de:d4:cc src 14:91:82:2a:64:cf
Fri May 22 19:38:20 2020 daemon.debug pppd[2273]: [service-name] [AC-cookie d3 07 58 7c 1c e5 63 ba 43 f2 4a 64 2f ee 5d 28]
Fri May 22 19:38:20 2020 daemon.debug pppd[2273]: Recv PPPOE Discovery V1T1 PADS session 0x1 length 4
Fri May 22 19:38:20 2020 daemon.debug pppd[2273]: dst 14:91:82:2a:64:cf src 84:26:2b:de:d4:cc
Fri May 22 19:38:20 2020 daemon.debug pppd[2273]: [service-name]
Fri May 22 19:38:20 2020 daemon.debug pppd[2273]: PADS: Service-Name: ''
Fri May 22 19:38:20 2020 daemon.info pppd[2273]: PPP session is 1
Fri May 22 19:38:20 2020 daemon.warn pppd[2273]: Connected to 84:26:2b:de:d4:cc via interface eth1.2
Fri May 22 19:38:20 2020 daemon.debug pppd[2273]: using channel 1
Fri May 22 19:38:20 2020 kern.info kernel: [ 12.303626] pppoe-wan: renamed from ppp0
Fri May 22 19:38:20 2020 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Fri May 22 19:38:20 2020 daemon.info pppd[2273]: Using interface pppoe-wan
Fri May 22 19:38:20 2020 daemon.notice pppd[2273]: Connect: pppoe-wan <--> eth1.2
Fri May 22 19:38:20 2020 daemon.debug pppd[2273]: sent [LCP ConfReq id=0x1 <mru 1412> <magic 0x372f770b>]
Fri May 22 19:38:20 2020 daemon.debug pppd[2273]: rcvd [LCP ConfAck id=0x1 <mru 1412> <magic 0x372f770b>]
Fri May 22 19:38:20 2020 user.notice ucitrack: Setting up /etc/config/network reload dependency on /etc/config/dhcp
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.515925] ieee80211 phy1: regdomain: ETSI
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.520134] ieee80211 phy1: Channel: 1: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.525080] ieee80211 phy1: a a a a a a a a a a a a 0 0 0 0
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.530775] ieee80211 phy1: Channel: 2: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.535697] ieee80211 phy1: a a a a a a a a a a a a 0 0 0 0
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.541385] ieee80211 phy1: Channel: 3: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.546299] ieee80211 phy1: a a a a a a a a a a a a 0 0 0 0
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.551986] ieee80211 phy1: Channel: 4: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.556911] ieee80211 phy1: a a a a a a a a a a a a 0 0 0 0
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.562612] ieee80211 phy1: Channel: 5: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.567532] ieee80211 phy1: a a a a a a a a a a a a 0 0 0 0
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.573260] ieee80211 phy1: Channel: 6: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.578175] ieee80211 phy1: a a a a a a a a a a a a 0 0 0 0
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.583883] ieee80211 phy1: Channel: 7: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 user.notice ucitrack: Setting up /etc/config/network reload dependency on /etc/config/radvd
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.588795] ieee80211 phy1: a a a a a a a a a a a a 0 0 0 0
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.594505] ieee80211 phy1: Channel: 8: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 user.notice ucitrack: Setting up /etc/config/wireless reload dependency on /etc/config/network
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.599416] ieee80211 phy1: a a a a a a a a a a a a 0 0 0 0
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.605120] ieee80211 phy1: Channel: 9: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.610024] ieee80211 phy1: a a a a a a a a a a a a 0 0 0 0
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.615726] ieee80211 phy1: Channel: 10: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/luci-splash
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.620719] ieee80211 phy1: a a a a a a a a a a a a 0 0 0 0
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.626420] ieee80211 phy1: Channel: 11: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/qos
Fri May 22 19:38:20 2020 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/miniupnpd
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.631410] ieee80211 phy1: a a a a a a a a a a a a 0 0 0 0
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.637111] ieee80211 phy1: Channel: 12: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/sqm
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.642102] ieee80211 phy1: a a a a a a a a a a a a 0 0 0 0
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.647802] ieee80211 phy1: Channel: 13: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.652805] ieee80211 phy1: a a a a a a a a a a a a 0 0 0 0
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.658527] ieee80211 phy0: regdomain: ETSI
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.662756] ieee80211 phy0: Channel: 36: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 user.notice ucitrack: Setting up /etc/config/dhcp reload dependency on /etc/config/odhcpd
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.667762] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.673466] ieee80211 phy0: Channel: 40: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.678457] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.684158] ieee80211 phy0: Channel: 44: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.689150] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.694856] ieee80211 phy0: Channel: 48: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.699848] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.705549] ieee80211 phy0: Channel: 52: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 user.notice ucitrack: Setting up non-init /etc/config/fstab reload handler: /sbin/block mount
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.710542] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.716246] ieee80211 phy0: Channel: 56: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.721252] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.726963] ieee80211 phy0: Channel: 60: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 user.notice ucitrack: Setting up /etc/config/system reload trigger for non-procd /etc/init.d/led
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.731955] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.737657] ieee80211 phy0: Channel: 64: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.742665] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 user.notice ucitrack: Setting up /etc/config/system reload dependency on /etc/config/luci_statistics
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.748353] ieee80211 phy0: Channel: 100: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.753445] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 user.notice ucitrack: Setting up /etc/config/system reload dependency on /etc/config/dhcp
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.759132] ieee80211 phy0: Channel: 104: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.764221] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.769907] ieee80211 phy0: Channel: 108: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.775008] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.780698] ieee80211 phy0: Channel: 112: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.785803] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.791492] ieee80211 phy0: Channel: 116: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.796589] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.802279] ieee80211 phy0: Channel: 120: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.807385] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.813171] ieee80211 phy0: Channel: 124: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.818261] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.824049] ieee80211 phy0: Channel: 128: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.829136] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.834916] ieee80211 phy0: Channel: 132: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.840002] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.845790] ieee80211 phy0: Channel: 136: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.850891] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.856689] ieee80211 phy0: Channel: 140: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.861773] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.867551] ieee80211 phy0: Channel: 149: 0x0 0x0 0xf
Fri May 22 19:38:20 2020 kern.debug kernel: [ 12.872641] ieee80211 phy0: d d d d d d d d e e e e e e e e
Fri May 22 19:38:20 2020 kern.info kernel: [ 13.042527] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
Fri May 22 19:38:20 2020 daemon.notice procd: /etc/rc.d/S96led: setting up led WAN
Fri May 22 19:38:20 2020 daemon.notice procd: /etc/rc.d/S96led: setting up led USB 1
Fri May 22 19:38:20 2020 daemon.notice procd: /etc/rc.d/S96led: setting up led USB 2
Fri May 22 19:38:20 2020 daemon.notice procd: /etc/rc.d/S96led: setting up led USB 2 SS
Fri May 22 19:38:21 2020 daemon.info procd: - init complete -
Fri May 22 19:38:21 2020 user.notice mac80211: Failed command: iw phy phy0 set antenna all all
Fri May 22 19:38:21 2020 daemon.notice netifd: radio0 (2194): command failed: Not supported (-95)
Fri May 22 19:38:21 2020 user.notice mac80211: Failed command: iw phy phy0 set distance 0
Fri May 22 19:38:21 2020 user.notice mac80211: Failed command: iw phy phy1 set antenna all all
Fri May 22 19:38:21 2020 daemon.notice netifd: radio1 (2195): command failed: Not supported (-95)
Fri May 22 19:38:21 2020 user.notice mac80211: Failed command: iw phy phy1 set distance 0
Fri May 22 19:38:21 2020 daemon.err hostapd: Configuration file: /var/run/hostapd-phy1.conf
Fri May 22 19:38:21 2020 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Fri May 22 19:38:21 2020 kern.debug kernel: [ 13.800597] ieee80211 phy1: change: 0xffffffff
Fri May 22 19:38:21 2020 kern.info kernel: [ 13.919657] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
Fri May 22 19:38:21 2020 kern.debug kernel: [ 14.041424] ieee80211 phy0: change: 0xffffffff
Fri May 22 19:38:21 2020 kern.info kernel: [ 14.175659] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Fri May 22 19:38:21 2020 kern.info kernel: [ 14.181635] br-lan: port 2(wlan1) entered blocking state
Fri May 22 19:38:21 2020 kern.info kernel: [ 14.187009] br-lan: port 2(wlan1) entered disabled state
Fri May 22 19:38:21 2020 kern.info kernel: [ 14.192450] device wlan1 entered promiscuous mode
Fri May 22 19:38:21 2020 kern.info kernel: [ 14.197215] br-lan: port 2(wlan1) entered blocking state
Fri May 22 19:38:21 2020 kern.info kernel: [ 14.202563] br-lan: port 2(wlan1) entered forwarding state
Fri May 22 19:38:21 2020 kern.info kernel: [ 14.208109] br-lan: port 3(wlan0) entered blocking state
Fri May 22 19:38:21 2020 kern.info kernel: [ 14.213449] br-lan: port 3(wlan0) entered disabled state
Fri May 22 19:38:21 2020 kern.info kernel: [ 14.218862] device wlan0 entered promiscuous mode
Fri May 22 19:38:21 2020 kern.info kernel: [ 14.223614] br-lan: port 3(wlan0) entered blocking state
Fri May 22 19:38:21 2020 kern.info kernel: [ 14.228948] br-lan: port 3(wlan0) entered forwarding state
Fri May 22 19:38:21 2020 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Fri May 22 19:38:21 2020 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->COUNTRY_UPDATE
Fri May 22 19:38:22 2020 kern.info kernel: [ 14.234948] br-lan: port 2(wlan1) entered disabled state
Fri May 22 19:38:22 2020 kern.info kernel: [ 14.240812] br-lan: port 3(wlan0) entered disabled state
Fri May 22 19:38:22 2020 daemon.notice hostapd: wlan1: interface state COUNTRY_UPDATE->HT_SCAN
Fri May 22 19:38:22 2020 kern.debug kernel: [ 14.246699] ieee80211 phy1: change: 0x100
Fri May 22 19:38:22 2020 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->HT_SCAN
Fri May 22 19:38:22 2020 kern.debug kernel: [ 14.259458] ieee80211 phy1: change: 0x40
Fri May 22 19:38:22 2020 kern.debug kernel: [ 14.260249] ieee80211 phy0: change: 0x100
Fri May 22 19:38:22 2020 kern.debug kernel: [ 14.276461] ieee80211 phy0: change: 0x40
Fri May 22 19:38:22 2020 kern.debug kernel: [ 14.462415] ieee80211 phy1: change: 0x40
Fri May 22 19:38:22 2020 kern.debug kernel: [ 14.492416] ieee80211 phy0: change: 0x40
Fri May 22 19:38:22 2020 kern.debug kernel: [ 14.682418] ieee80211 phy1: change: 0x40
Fri May 22 19:38:22 2020 kern.debug kernel: [ 14.712417] ieee80211 phy0: change: 0x40
Fri May 22 19:38:22 2020 kern.debug kernel: [ 14.819423] ieee80211 phy0: change: 0x100
Fri May 22 19:38:22 2020 daemon.err hostapd: Using interface wlan0 with hwaddr 00:25:9c:13:c0:61 and ssid "WRT1900ACS-50"
Fri May 22 19:38:22 2020 kern.debug kernel: [ 14.885520] ieee80211 phy0: change: 0x100
Fri May 22 19:38:22 2020 kern.debug kernel: [ 14.892419] ieee80211 phy1: change: 0x40
Fri May 22 19:38:22 2020 kern.debug kernel: [ 14.900374] ieee80211 phy0: change: 0x42
Fri May 22 19:38:22 2020 daemon.debug pppd[2273]: rcvd [LCP ConfReq id=0xf6 <mru 1492> <magic 0xdd7e7df>]
Fri May 22 19:38:22 2020 daemon.debug pppd[2273]: sent [LCP ConfAck id=0xf6 <mru 1492> <magic 0xdd7e7df>]
Fri May 22 19:38:22 2020 kern.info kernel: [ 15.075455] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Fri May 22 19:38:22 2020 kern.info kernel: [ 15.081888] br-lan: port 3(wlan0) entered blocking state
Fri May 22 19:38:22 2020 kern.info kernel: [ 15.087230] br-lan: port 3(wlan0) entered forwarding state
Fri May 22 19:38:22 2020 kern.debug kernel: [ 15.102421] ieee80211 phy1: change: 0x40
Fri May 22 19:38:22 2020 daemon.debug pppd[2273]: sent [LCP EchoReq id=0x0 magic=0x372f770b]
Fri May 22 19:38:22 2020 daemon.debug pppd[2273]: sent [PAP AuthReq id=0x1 user="@tedata.net.eg" password=]
Fri May 22 19:38:22 2020 daemon.debug pppd[2273]: rcvd [LCP ConfReq id=0xf6 <mru 1492> <magic 0xdd7e7df>]
Fri May 22 19:38:22 2020 daemon.debug pppd[2273]: sent [LCP ConfReq id=0x2 <mru 1412> <magic 0xb130fdd6>]
Fri May 22 19:38:22 2020 daemon.debug pppd[2273]: sent [LCP ConfAck id=0xf6 <mru 1492> <magic 0xdd7e7df>]
Fri May 22 19:38:22 2020 daemon.debug pppd[2273]: rcvd [LCP EchoRep id=0x0 magic=0xdd7e7df]
Fri May 22 19:38:22 2020 daemon.debug pppd[2273]: rcvd [LCP TermReq id=0xf7]
Fri May 22 19:38:22 2020 daemon.debug pppd[2273]: sent [LCP TermAck id=0xf7]
Fri May 22 19:38:22 2020 daemon.notice hostapd: wlan0: interface state HT_SCAN->ENABLED
Fri May 22 19:38:22 2020 daemon.notice hostapd: wlan0: AP-ENABLED
Fri May 22 19:38:22 2020 daemon.notice netifd: Network device 'wlan0' link is up
Fri May 22 19:38:22 2020 daemon.notice pppd[2273]: Modem hangup
Fri May 22 19:38:22 2020 daemon.notice pppd[2273]: Connection terminated.
Fri May 22 19:38:23 2020 daemon.debug pppd[2273]: Send PPPOE Discovery V1T1 PADT session 0x1 length 20
Fri May 22 19:38:23 2020 daemon.debug pppd[2273]: dst 84:26:2b:de:d4:cc src 14:91:82:2a:64:cf
Fri May 22 19:38:23 2020 daemon.debug pppd[2273]: [AC-cookie d3 07 58 7c 1c e5 63 ba 43 f2 4a 64 2f ee 5d 28]
Fri May 22 19:38:23 2020 daemon.info pppd[2273]: Sent PADT
Fri May 22 19:38:23 2020 kern.debug kernel: [ 15.312426] ieee80211 phy1: change: 0x40
Fri May 22 19:38:23 2020 daemon.info pppd[2273]: Exit.
Fri May 22 19:38:23 2020 daemon.notice netifd: Interface 'wan' is now down.

No PADO response. Rebooting the router or restarting the WAN Interface does not help. I have to actually disconnect the DSL line or restart the Bridge modem to get it to get to work.

Now in case things are working fine, The Speedtest.net speed is around 2.5 ~ 10 Mbps, with really 50ms to 250ms jitter, which was previously around 0 ~ 1ms.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd60:4469:9963::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'pppoe'
	option username '<hidden>@tedata.net.eg'
	option password '<hidden>'
	option ipv6 'auto'
	option mtu '1420'
	option pppd_options 'debug'
	option delegate '0'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'
	option auto '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 1 2 3 4t 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '4 6t'


Can someone shed any light on how to troubleshoot the problem?

Do you have a DSL filter installed to isolate your VDSL from the phone interference?

I think by filter you mean a splitter, which splits the main line to two lines, one for the modem and one for the telephone line as shown in the first picture above

No, I meant a DSL filter. Normally, a phone line comes into a home then then is split into two lines. One line goes to the modem and must have a DSL filter. The other line goes to your phone.
I see you put a splitter after the modem. Why? Is this a regular home line or VoIP?

My bad, filter goes to the phone line

At least your initial picture doesn't make any sense.

Yes, "splitter" and "line filter" are the same, but the way you're using it does not work. The splitter (if required for your connection type, which has gotten increasingly rare on modern BNG platforms), needs to go in front of the modem - filtering out the lower bands necessary for POTS/ ISDN and the xDSL signals above, so to serve any purpose, it would need to go in front of the Huawei HG630v2 (but given the structure, I really doubt it is needed there).

The splitter has no purpose at all behind the xDSL modem, you can't share a single cable (splitter or not) for your analogue phones and your (wrt1900acs) router, even trying might blow up the wrt1900acs (POTS signals would go up to 90 V AC, while your router's WAN port is ethernet only - and doesn't provide any modem functionality).

Like this. The modem need to be behind the splitter. It is possible that your splitter already includes a filter, but it still needs to be before the modem.

Guys...I am really sorry...You are right. The picture is completely wrong. I didn't notice it till now. (It is a DLink DSL-30CF)

It is Line => Splitter => Modem (Output1) / Telephone (Output2)


My Apologies again

Openwrt if very stable on a VDSL line in my many years of using it. From your description you may have a line issue and/or a modem failing.

I am suspecting the modem here to be honest, But I have no idea how to make sure of this. This problem has started to happen 2 weeks ago. I have been using openwrt over 6 months now without any problem. . Perhaps there is a problem with the configuration on the openwrt side, too? I doubt it but I don't want to eliminate the possibility either.

Check modem logs to start with.

No problem with the logs expect a rare (ERROR_NO_CARRIER) event and I am troubleshooting it at the moment.

Is the modem supplied by your ISP? If not, it's firmware may not be compatible. Wrong annex or other issue

Yes. It is the modem supplied by my ISP with their firmware running.

The first step then is to configure it as a router and have it manage the PPPoE connection. If you can prove the instability that way, you can blame the ISP and get a new modem from them.

I think you should check the adsl splitter first to make sure it's not bad.
By my experience of using adsl many years ago, the first bad thing after many years of use is the adsl splitter.
You can check by disconnecting all the telephones, connecting the phone line wired directly to the modem, and see if the problem still exists.

An update
The problems are not happening with the provided ISP router. Got back to OpenWRT and it is still happening. I can also confirm that it is happening with someone else using LEDE on WRT3200ACM. He told me he also noticed getting a different tone lately, since this problem has started to happen. I have been into loops with the ISP Customer Service telling me, no configuration changes have been made. Do you think the ISP is pushing new configurations silently to fight the use of Custom Routers?! and What different settings may I fiddle with?
I have set LCP echo failure threshold / LCP echo interval
to 5 /5 and completely deleted WAN6 interface and disabled all settings related to IPv6. Still under testing, but getting alot of this error in the log
daemon.err dnsmasq[3638]: failed to send packet: Permission denied

Could this be related: PPPoE disconnects every few hours ?

I doubt, the simptoms are totally different.

This means the remote end tried to close the connection. The reason... is only know to the ISP staff (or not even them).

Does the ISP support the use of custom routers? (there was a country wide legal issue about this in Germany, the people claiming, they should have this right... google it)

1 Like