Simple DS-lite implementation in GNS3 topology

Hello everyone,

Anyone can help me explain why I cannot successfully implement DS-lite in my communication topology? In this scenario, I configured that: If client uses IPv6 to communicates with server, it will communicate normally through IPv6 network. If client uses IPv4, DS-lite will be applied to connect with server.

After implementing that, IPv6 communication works but DS-lite does not. Client (with IP address 10.0.0.154) cannot ping server (192.168.1.201).

In the DS-lite documentation Link here, it is only needed to configure B4 router with command:

config interface 'wan'
        option proto 'dslite'
        option peeraddr '2001:db8:2::2'

Then ds-lite operation requires that IPv4 NAT is disabled, but I cannot figure out which command. I thought that is masq in role of file /etc/config/firewall, but it seems to be wrong after configuration.

Down here is what I did with router B4 and router AFTR:

  • Router B4:
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd46:ba8e:90ff::/48'

config interface 'lan'
        option type 'bridge'
        option device 'eth0'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option ip6addr '2001:db8:1::1/64'
        option ip6assign '64'

config interface 'wan'
        option device 'eth2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth2'
        option proto 'dhcpv6'

config interface 'wan6'
        option device 'eth1'
        option proto 'static'
        option ip6addr '2001:db8:2::1/64'

config interface 'wan'
        option proto 'dslite'
        option peeraddr '2001:db8:2::2'

config route6 'net1'
        option interface 'wan6'
        option target '2001:db8:3::/64'
        option gateway '2001:db8:2::2'
  • Router AFTR:
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdfa:e6fc:c7f0::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6addr '2001:db8:3::1/64'
        option ip6assign '64'

config interface 'wan'
        option device 'eth2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth2'
        option proto 'dhcpv6'

config interface 'wan6'
        option device 'eth1'
        option proto 'static'
        option ip6addr '2001:db8:2::2/64'

config route6 'net2'
        option interface 'wan6'
        option target '2001:db8:1::/64'
        option gateway '2001:db8:2::1'

What software on "Router AFTR" provides the DS-Lite AFTR functionality?