Shared Drive access

Dear All,
In reference to my post on 22 dec.

I got all working except the shared drive issue. I have one shared drive attached to machine.
I can access this machine from 192*** network. some how shared drive \\share is not accessible. but when I join 10* network same is available. Can some one provide me hint to fix this issue ?

please refer my above link for configuration.

Disabled firewall or opened ports for windows sharing on the 10 router?

Shouldn't you be using the 200 IP when going from the 192 subnet?

Why the double NAT, in the 1st place?

This is the firewall setting on second router.

That's one answer out of three...

You need a static route on the main router... does that device have the ability to add user-defined static routes?

If so, your route will look like this: via
(or if it uses classic subnet mask definitions, it would be subnet mask via

Here are the details. Do you recommend me to add explicitly ?

Is this on the main router or the secondary router?

In your diagram, you show the address of the second router as, but here is is showing -- which one is correct?

I am sorry.. after reboot became (Correct) .. Now I made static so it wont change.


When you made this static, how did you do it? Did you use a DHCP reservation on the main router? Or using proto static on the second router?

And you didn't answer this, regarding the static route you showed earlier.


These static route settings I have made on main router. DHCP reservation or proto static .. I have not understood this. On second router there is nothing static under routes.

Under DHCP on main router

You said this earlier:

How did you achieve this? You had to change settings on one router or the other... what did you do to make it "static"?

Good. That is exactly what should be done.

On home page of router .. it has option to make static

On main router (192****). under DHCP static least, I can not have ip of second router (10***)

that's fine. You've done those things correctly.

Now, on the second router: you should be able to disable masquerading on the wan firewall zone. Make sure that internet connectivity still works on the network.

Internet connectivity works on second router and DNS masquerading is disabled on second router.

Still shared folder does not work.

Great! That means the route is working

Based on the screenshot, I would expect that it would work from an OpenWrt firewall standpoint. So, the next thing to check is the host that has the shared folder -- make sure that it will accept connections from other subnets. Windows, for example, blocks this behavior by default, and you must adjust the windows firewall to allow this to work.