Sha512-arm.ko' is missing "Solved"

I am trying to compile a snapshot build 22.03.5 and keep receiving this near the end of the building image.

ERROR: module '/home/User/openwrt-imagebuilder-22.03.5-kirkwood.Linux-x86_64/openwrt/build_dir/target-arm_xscale_musl_eabi/linux-kirkwood_generic/linux-5.15.110/arch/arm/crypto/sha512-arm.ko' is missing.
make[3]: *** [modules/ /home/User/openwrt-imagebuilder-22.03.5-kirkwood.Linux-x86_64/openwrt/bin/targets/kirkwood/generic/packages/kmod-crypto-sha512_5.15.110-1_arm_xscale.ipk] Error 1
make[3]: Leaving directory '/home/User/openwrt-imagebuilder-22.03.5-kirkwood.Linux-x86_64/openwrt/package/kernel/linux'
time: package/kernel/linux/compile#3.75#0.29#3.96
    ERROR: package/kernel/linux failed to build.
make[2]: *** [package/Makefile:116: package/kernel/linux/compile] Error 1
make[2]: Leaving directory '/home/User/openwrt-imagebuilder-22.03.5-kirkwood.Linux-x86_64/openwrt'
make[1]: *** [package/Makefile:110: /home/User/openwrt-imagebuilder-22.03.5-kirkwood.Linux-x86_64/openwrt/staging_dir/target-arm_xscale_musl_eabi/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/User/openwrt-imagebuilder-22.03.5-kirkwood.Linux-x86_64/openwrt'
make: *** [/home/User/openwrt-imagebuilder-22.03.5-kirkwood.Linux-x86_64/openwrt/include/ world] Error 2

Twice is enough and so I am not familiar of this error but doing a search it has been in the past, first time for me?

Any help would be appreciated and since this part of forum is about community builds projects and packages might know or point me in the right direction.


1 Like

Having the same issue trying to build latest master for Raspberry Pi 4B - this has gone on for 1-2 weeks at this point. (The first time I ran into this a week or two ago, I was too busy to dig down and resolve it and hoped it would get fixed upstream, but it's still problematic.)

I suspect the culprit may be - but I can't figure out how that isn't breaking sha1 too if it is the problem.



Thanks. Trying adding CONFIG_ARM_CRYPTO to target/linux/bcm27xx/bcm2711/config-5.15 to see if that fixes it for me.

Looks reasonable to add CONFIG_ARM_CRYPTO=y to correct it, I'd like to hear from Entropy512 results firsts.

Thanks anomeome.


No go here, but perhaps there's some weird corner cases with arm64 here that need further poking.

EDIT: WEIRD. Somehow my config got switched from bcm2711 to bcm2709 at some point... Retrying. Do need to fix this for my one bcm2709 target anyway though.

EDIT 2: OK, somehow my config file for bcm2711 got corrupted. I have a separate config for bcm2709, adding CONFIG_ARM_CRYPTO to target/linux/bcm27xx/bcm2709/config-5.15 (NOT bcm2711/config-5.15) fixed it.

I think this problem stems from this submission kernel: crypto: fix architecture specific modules. I have the same problem when compiling the ipq806x target. add CONFIG_ARM_CRYPTO=y to target/linux/ipq806x/config-5.15 to solve the problem

adding the CONFIG_ARM_CRYPTO to the config-5.15 does continue to build the snapshot but it isn't official yet it is a tempory fix I assume?

I originally needed to retest my EA3500 but ran into the error failing near the end of build process, I am sure there should be a official word sometime soon on this topic.


I would suggest that relevant data regarding device and resolution status should be added to the PR linked above to expedite a solution being committed to master.

Edit: it has been committed

1 Like

Should this thread be closed now or left open?

You can just select the solved by to close.

1 Like

Sorry but I just edited the post unless I had over looked something?


I still had some issue with ipv6, disabling or stopping wan6 helped with the packet loss and losing down stream issues.

Another was sqm wouldn't perform properly after disabling wan6, this was 22.03.5 imagebuilder and the snapshot image.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.